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Safety Information
Important Information

NOTICE Read these instructions carefully, and look at the equipment to become familiar with 
the device before trying to install, operate, or maintain it. The following special 
messages may appear throughout this documentation or on the equipment to warn 
of potential hazards or to call attention to information that clarifies or simplifies a 
procedure.

The addition of this symbol to a Danger or Warning safety label indicates
that an electrical hazard exists, which will result in personal injury if the
instructions are not followed.

This is the safety alert symbol. It is used to alert you to potential personal
injury hazards. Obey all safety messages that follow this symbol to avoid
possible injury or death.

DANGER indicates an imminently hazardous situation, which, if not avoided, will 
result in death, serious injury, or equipment damage.

DANGER

WARNING
WARNING indicates a potentially hazardous situation, which, if not avoided, can result 
in death, serious injury, or equipment damage.

CAUTION
CAUTION indicates a potentially hazardous situation, which, if not avoided, can result 
in injury or equipment damage.
  11/2004 7



Safety Information
PLEASE NOTE Electrical equipment should be serviced only by qualified personnel. No responsi-
bility is assumed by Schneider Electric for any consequences arising out of the use 
of this material. This document is not intended as an instruction manual for untrained 
persons.
© 2004 Schneider Electric. All Rights Reserved.
8   11/2004



About the Book
At a Glance

Document Scope This manual describes the requirements and procedures for connecting MMI 
terminals Magelis XBT to an Advantys STB Island taking into account the various 
fieldbuses that are supported by Advantys STB. Knowledge about the respective 
hardware, the programming software, the bus configuration tool and the MMI 
configuration tool is required. Additionally, the user should be familiar with the 
fieldbuses used.

Validity Note This application description is valid for the Advantys software starting with Version 
1.0, XBTL1000 V4.2, Vieijo Look V1.0, Sycon SPU LF• CD28 M  (called SyCon 
below), CMD Tool starting with Version V4.5, Concept starting with Version 2.6 SR1, 
PL7 starting with Version 4.4, Unity Pro starting with Version 2.0. 
Screen shots and procedures shown in this book refer to the versions of the 
abovementioned software programs.
Schneider Electric is not liable for any errors that may appear in this document. If 
you would like to make any suggestions for improvement or amendments or you 
have found errors in this publication, please notify us.
No part of this document may be reproduced in any form or by any means, electronic 
or mechanical, including photocopying, without express written permission of 
Schneider Electric. This includes the copying of the document.
The data and illustrations found in this documentation are not binding. We reserve 
the right to modify our products in line with our policy of continuous product 
development. The information in this document is subject to change without notice 
and should not be construed as a commitment by Schneider Electric.
  11/2004 9



About the Book
Related 
Documents

Product Related 
Warnings

Observe all pertinent state, regional, and local safety regulations when installing and 
using this product. For reasons of safety and to assure compliance with documented 
system data, only the manufacturer should perform repairs to components.
If controllers are used in applications with particular safety-technical requirements, 
please observe the appropriate instructions.
Failure to use Schneider Electric software or approved software with our hardware 
products may result in injury, harm, or improper operating results.
Failure to heed the product-relevant warnings can cause injuries or damage to 
devices.

User Comments We welcome your comments about this document. You can reach us by e-mail at 
techpub@schneider-electric.com

Title of Documentation Reference Number

The Advantys STB Hardware Components Reference Guide 890USE17202

The Advantys STB Standard Profibus DP Network Interface 
Applications Guide

890USE17302

The Advantys STB Standard INTERBUS Network Interface 
Applications Guide

890USE17402

The Advantys STB Standard DeviceNet Network Interface 
Applications Guide

890USE17502

The Advantys STB Standard CANopen Network Interface 
Applications Guide

890USE17602

The Advantys STB Standard Ethernet Modbus TCP/IP Network 
Interface Applications Guide

890USE17702

The Advantys STB Standard Modbus Plus Network Interface 
Applications Guide

890USE17802

The Advantys STB Standard Fipio Network Interface Applications 
Guide

890USE17902

The Advantys STB System Planning and Installation Guide 890USE17102

The Advantys STB Configuration Software Quick Start User Guide 890USE18002

Concept User Manual 840 USE 503 02

PL7 Reference Manual TLX DR PL7 xx eng

Magelis XBT-H/P/E/HM/PM Instruction Manual XBT X000DE

Manuals of the respective bus configuration tools
10   11/2004
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I

MMI terminals Magelis XBT• to 
Advantys STB Island
Overview

What will you 
find in this part?

This part contains general information and an overview for the application 
description via the connection of MMI terminals Maglis XBT• to an Advantys STB 
Island taking into account the various fieldbus systems.

What's in this 
Part?

This part contains the following chapters:

Chapter Chapter Name Page

1 General overview 13

2 Hardware and software requirements 17
11
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1

General overview
At a Glance

Introduction In this chapter you will find a brief overview for the connection of a Magelis terminal 
to an Advantys STB Island.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Connecting a Magelis terminal to Advantys STB Island 14

Principal procedure for connecting an MMI terminal to Advantys STB Island 15
13



General overview
Connecting a Magelis terminal to Advantys STB Island

Overview You can connect an MMI terminal of the type Magelis XBT• to an Advantys STB 
Island directly via the CFG interface of the network interface module (NIM) and 
configure it in the context of the island bus. Communication occurs via Modbus 
protocol. 

Configuration 
example

The following figure shows a sample configuration: 

K Connections for the transfer of the configurations and programs

B Connection for the operation of the MMI terminal to Advantys STB Island
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General overview
Principal procedure for connecting an MMI terminal to Advantys STB Island

Overview Several steps are required to connect an MMI terminal of the type Magelis XBT• to 
an Advantys STB Island. 
First you must provide the physical requirements for operating the application, that 
is, all hardware components: 
� Fieldbus master
� the individual fieldbus nodes including the Advantys STB Island, MMI terminal, 
� fieldbus cabling
�  connection cable for configuring

Then the configuration and programming of the individual application parts takes 
place with the appropriate software.

Basic flow of the 
configuration

The table below describes in brief the basic flow that must be carried out to connect 
an MMI terminal Magelis XBT•:

Phase Software Description

Provision of the required 
hardware and software 

- The following components must be provided:
� Fieldbus master
� Advantys STB Island hardware with the desired network 

interface module
� MMI terminal Magelis XBT•
� cable for configuration and operation of the applications
� Software for the configuration and programming
For additional information, see the sections Hardware 
requirements, p. 18 and Software requirements, p. 26.

Configuration of Advantys 
STB Island and MMI 
connection

Advantys 
Configuration 
Software

Specify the Advantys STB Island hardware configuration and the 
communication with an MMI terminal for:
� ProfibusDP Communication (See Configuration of the 

Advantys STB Island with Profibus DP communication, p. 36)
� INTERBUS Communication (See Configuration of the 

Advantys STB Island mit INTERBUS communication, p. 90)
� CANopen Communication (See Configuration of the Advantys 

STB Island with CANopen communication, p. 126)

Configuration of the fieldbus SyCon or CMD 
(depending on the 
fieldbus master 
selected) 

Configuration of the fieldbus used:
� ProfibusDP Communication (See Bus configuration for 

Profibus DP, p. 41)
� INTERBUS Communication (See Bus configuration for 

INTERBUS, p. 94)
� CANopen Communication (See Bus configuration for 

CANopen, p. 132)
  11/2004 15



General overview
PLC Configuration Concept, PL7 or 
Unity Pro

Configuration, bus configuration and programming of the PLC 
used with the appropriate software program:
� TSX Quantum with Concept for Profibus DP Communication 

(See Configuration using Concept, p. 56)
� TSX Quantum with Concept for INTERBUS Communication 

(See Startup of the INTERBUS Master 140 NOA 622 00, p. 98)
� TSX Premium with PL7 for CANopen Communication (See 

CANopen configuration under PL7, p. 148)

Configuration of the MMI 
terminal Magelis XBT•

Configuration 
software 
XBTL 1000 or 
Vijeo-Designer (for 
Magelis XBT G•)

Creating and configuring the application for the human-machine 
dialog for:
� ProfibusDP Communication (See Configuration of a Magelis 

XBT for connection to an Advantys STB Island with Profibus 
DP network interface, p. 77)

� INTERBUS Communication (See Configuration of a Magelis 
XBT for connection to an Advantys STB Island with INTERBUS 
network interface, p. 114)

� CANopen Communication (See Configuration of a Magelis 
XBT for connection to an Advantys STB Island with CANopen 
network interface, p. 159)

Load and start the individual 
applications

Advantys
XBTL 1000
Concept/PL7/
Unity Pro

� Load the previously-created configurations and programs into 
the appropriate devices.

� Start the individual applications

Create the hardware 
connection between 
Advantys STB Island and 
Magelis

- The XBTZ988 connection cable is inserted between the Advantys 
STB Island and the Magelis XBT•.

Documentation Advantys
XBTL 1000
Concept/PL7/
Unity Pro
SyCon

Print various information concerning the bus configuration and the 
projects

Phase Software Description
16   11/2004
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2

Hardware and software 
requirements
At a Glance

Introduction This chapter lists the requirements for hardware and software for the application 
example MMI terminal to Advantys STB Island.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Hardware requirements 18

Software requirements 26
17



Hardware and software-requirements
Hardware requirements

What hardware is 
required?

The following components are required:
� Advantys STB Island with the desired network interface module for the fieldbus 

used (See Advantys STB Island configuration, p. 19)
� PLC with corresponding fieldbus master,  e.g.  TSX Quantum with 

140 CRP 811 00 for Profibus DP or with NOA 622 for INTERBUS (See TSX 
Quantum with fieldbus master for Profibus DP or INTERBUS, p. 20) or TSX 
Premium with TSX CPP 110 for CANopen. (See TSX Premium with fieldbus 
master for CANopen, p. 21)

� PC for the configuration and programming software (See PC for configuring the 
system components, p. 22)

� MMI terminal  (See MMI terminal, p. 23)
� various cables for the fieldbus operation and the loading and operation of the 

applications (See Cable, p. 23)
18   11/2004



Hardware and software-requirements
Advantys STB 
Island 
configuration

Configuration of the Advantys STB Island:  

Modules of the Advantys STB Island:

Physical 
address

Island Bus 
Address

Module

1 127 STB NDP 2212; network interface module for Profibus DP 
(examplary)
When connecting to another fieldbus, the corresponding 
network interface module must be used here.

2 - STB PDT 3100; power distribution module 24 VDC

3 1 STB AVI 1270
Analog inputs (2 channels, -10V ... +10V), 24 VDC

4 2 STB DDI 3420; dig. Inputs (4 channels), 24 VDC

5 3 STB DDO 3600; dig. Outputs (6 channels), 24 VDC

6 4 STB DDI 3420; dig. Inputs (4 channels), 24 VDC

7 5 STB DDO 3230; dig. Outputs (2 channels), 24 VDC

8 - STB XMP 1100; bus termination

1

1/127 2/- - 3/1 4/2 5/3 6/4 7/5 8/- -

NDP 2212

PD
T 

31
00

AV
I 1

27
0

PD
T 

31
00

D
D

I 3
42

0

DA
O

 8
21

0

INPUT

OUTPUT

DC

A

B

A

B

D
D

O
 3

60
0

A

B

D
D

I 3
42

0

A

B

D
D

O
 3

23
0

A

B
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Hardware and software-requirements
TSX Quantum 
with fieldbus 
master for 
Profibus DP or 
INTERBUS

For the application examples, a Quantum controller with 140 CRP 811 00 is selected 
as Profibus DP master or 140 NOA 622 00 as INTERBUS master. 

Modules of the TSX Quantum:

Rack slot Module

1-1 140 CPS 214; power supply module 24 VDC

1-2 140 CPU 213 04; CPU

1-3 140 DDI 353 00; 32 digital inputs, 24 VDC

1-4 140 DDO 353 00; 32 digital outputs, 24 VDC

1-5 140 AVI 030 00; bipolar analog input module (8 channels)

1-6 140 AVO 020 00; analog output module (4 channels)

... Not configured

1-10 140 CRP 81100; Profibus DP Master module
or
140 NOA 622 00; INTERBUS Master module 

CPS CPU DDI DDO AVI AVO Field-
 bus-

1-101-1 1-2 1-3 1-4 1-5 1-6 1-7 1-8 1-9

master
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Hardware and software-requirements
TSX Premium 
with fieldbus 
master for 
CANopen

For the application example, a Premium controller with TSX CPP 110 is selected as 
CANopen master. 

Modules of the TSX Premium:

Rack slot Module

- TSX PSY 1610; power supply module 24 VDC

0 TSX P572623; processor with TSX CPP 110, PCMCIA card for CANopen 
communication

1 TSX ETY interface

2 TSX DEY 08D2;  digital input module with 8 channels, 24 VDC

3 TSX DSY 08T2;  digital output module with 8 channels, 24 VDC

4 free

P
S
Y

0 3 41 2

T
S
X

P

L
o
o

C
o
m
m

p
s

E
T
Y

P
O
R
T

D
E
Y

D
S
Y
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Hardware and software-requirements
PC for 
configuring the 
system 
components

Depending on the software used, the following system requirements are 
recommended for the PC:

Your PC must fulfill the highest requirements for all programs that you use.

Requirement for Advantys 
Configuration 
Software

XBT L 1000 
(configuration 
Magelis 
terminal)

Concept V2.6 
SR1

PL7 V4.4 Unity Pro V2.0

computer Pentium III or 
higher

Pentium 90 Pentium or 
higher

Pentium 500 
MHz

Pentium 1.2 GHz

Microsoft operating 
system

Windows 98,
Windows NT 
SP6
or
Windows 2000

Windows 95/98
or
Windows NT 4.X

Windows 98,
Windows 2000,
Windows XP 
Professional
or
Windows NT 
SP5

Windows XP 
Professional
or
Windows 2000 
SP2

Windows XP 
Professional
or
Windows 2000

RAM 256 MB of RAM 24 MB of RAM 24 MB 128 MB 512 MB

free hard disk space 150 MB 30 MB 150 MB 80 MB for 
software
and
25 MB for 
temporary 
directories

4 GB

Drive CD-ROM CD-ROM CD-ROM CD-ROM CD-ROM

Graphics adapter VGA
Resolution 
1024x768

VGA VGA
Resolution min. 
800x600

SVGA (24 bit)
Resolution 
800x600

VGA
Resolution 
1024x768

Pointing device Microsoft-
compatible 
mouse

Microsoft-
compatible 
mouse

Microsoft-
compatible 
mouse

Microsoft-
compatible 
mouse

Microsoft-
compatible 
mouse

Internet browser Microsoft 
Internet Explorer 
4.01 or higher

- - - Microsoft 
Internet Explorer 
5.5 or higher
22   11/2004



Hardware and software-requirements
MMI terminal The following can be used as MMI terminal:
� Magelis XTB-F
� Magelis XBT-H / P / E / HM / PM
� Magelis XBT-N (except XBT-N200 and XBT-N400)
� Magelis XBT-G

In the application example, an MMI terminal of the type Magelis XBT-PM 027010 is 
used.

Cable The following cables are required:

Item name Description

STB XCA 4002 Configuration cable for Advantys STB Island (RS232 SUBD/HE13):
� Connection between PC and KFG interface of the network 

interface module
� Connection between Magelis XBT-G and CFG interface of the 

network interface module for operating the Magelis terminal

XBT Z915 Configuration cable for Magelis XTB-F, XBT-H / P / E / HM / PM, 
XBT-N (except XBT-N200 and N400)

XBT ZG915 Configuration cable for Magelis XTB-G

990 NAA 263•• Configuration cable for TSX Quantum (Modbus) and programming 
cable for 140 NOA 622 00

XBT Z988 Cable for operating Magelis XBT-F, XBT-H / P / E / HM / PM, XBT-
N (except XBT-N200 and N400) as well as XBT-G on the CFG 
interface of Advantys STB Island

XBT Z9710 Cable for operating Magelis XBT-F, XBT-H / P / E / HM / PM, XBT-
N (except XBT-N200 and N400) as well as XBT-G on a PLC

fieldbus cabling Depending on the fieldbus used
Refer to the corresponding fieldbus documentation for further 
information.
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Hardware and software-requirements
Cable 
STB XCA 4002

Pin assignment cable STB XCA 4002, length 2.5 m: 

Legend

Signal Name Meaning

TxD Transmit Data

RxD Receive Data

DSR Data Set Ready

DTR Data Terminal Ready

RTS Request to send

CTS Clear to send

GND Ground

D-sub, 9-pin, connector 

7

5

3

1

8

6

4

2

HE13, 8-pin, connector
PC or MMI Advantys STB

5

7

2

4

8

6

1

2

3

4

6

7

TxD

RxD

DSR

DTR

RTS

CTS

GND

RxD

TxD

DTR

DSR

RTS

occupied
unused

D-Sub

1

2

3

4

5

6

7

8

98

5

CTS

GND
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Hardware and software-requirements
Cable XBTZ988 Pin assignment cable XBTZ988, length 2.5 m: 

Legend

Signal Name Meaning

TxD Transmit Data

RxD Receive Data

DSR Data Set Ready

DTR Data Terminal Ready

RTS Request to send

CTS Clear to send

GND Ground

D-sub, 25-pin, keys 

1

2

3

4

5

14
15

16

17
7

5

3

1

8

6

4

2

HE13, 8-pin, connector

6

7

8

9

10

19

20

21

22

11

12

13

24

25

18

23

Magelis XBT Advantys STB

5

7

1

2

4

6

8

3

2

7

12

8

TxD

RxD

GND

DSR

DTR

CTS

RTS

RxD

TxD

GND

IN2

0V

occupied
unused
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Hardware and software-requirements
Software requirements

What software is 
required for 
configuration?

For configuration of the individual system components you will need the following 
software:

Software for 
configuration of 
the fieldbuses

For the configuration of the various fieldbuses and fieldbus master you will need the 
following software:

System component Software version

Advantys STB Island Advantys Configuration Software ≥V1.0

Magelis XBT (except Magelis XBTG•) XBTL 1000 Version 4.2

Magelis XBTG• Vijeo-Designer Version 1.0

Fieldbuses and fieldbus master master see section Software for configuration of the 
fieldbuses, p. 26

Fieldbus Configuration software Fieldbus 
master

Programming Software

Profibus DP SyCon Version 2.8 Quantum with 
140 CRP 811

Concept Version 2.6 SR1

Premium with 
TSX PBY100

PL7 Version 4.4
or
Unity Pro XL Version 2.0

INTERBUS SyCon Version 2.8 Quantum with 
140 NOA 622

Concept Version 2.6 SR1

CMD-Tool Version 4.41 Quantum with 
140 NOA 611

Concept Version 2.6 SR1

Premium with 
TSX IBY 100 / 
TSX IBX 100

PL7 Version V4.3 or higher
or
Unity Pro XL Version 2.0

CANopen SyCon Version 2.8 Premium with 
TSX CPP 100/
110

PL 7 Version 4.3 or higher 
or
Unity Pro XL Version 2.0

Ethernet Concept Version 2.6 SR1
or
Unity Pro XL Version 2.0

Quantum with 
140 NOE 7••

Concept Version 2.6 SR1
or
Unity Pro XL Version 2.0

Fipio PL7 Version 4.4 Premium with 
TSX P 57453-
CPU

PL7 Version 4.4
or
Unity Pro XL Version 2.0
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II

Applications examples for the 
various fieldbuses 
Overview

What will you 
find in this part?

This part describes the application examples for the various fieldbuses that can be 
used with Advantys STB Island.

What's in this 
Part?

This part contains the following chapters:

Chapter Chapter Name Page

3 Application example for connecting an MMI terminal to 
Advantys STB Island with Profibus DP-NIM

29

4 Application example for connecting an MMI terminal to 
Advantys STB Island with INTERBUS-NIM

83

5 Application example for connecting an MMI terminal to 
Advantys STB Island with CANopen NIM 

119
27



Application examples
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Application example for 
connecting an MMI terminal to 
Advantys STB Island with 
Profibus DP-NIM
At a Glance

Introduction In this chapter you will find the application description for the connection of an MMI 
terminal Magelis XBT• to an Advantys STB Island with Profibus DP network 
interface. 

What's in this 
Chapter?

This chapter contains the following sections:

Section Topic Page

3.1 Application with Profibus DP communication 31

3.2 Configuration of an Advantys STB Island with MMI connection 
and Profibus DP network interface

35

3.3 Bus configuration for Profibus DP 41

3.4 Configuration using Concept 56

3.5 Data storage in Advantys and Concept for communication with 
Profibus DP

67

3.6 Configuration of a Magelis XBT for connection to an Advantys 
STB Island with Profibus DP network interface

77
29



MMI terminals to Advantys STB Island with Profibus DP-NIM
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MMI terminals to Advantys STB Island with Profibus DP-NIM
3.1 Application with Profibus DP communication

Introduction

Overview This section provides a brief overview of the hardware for the Profibus DP 
communication and of the applications.

What's in this 
Section?

This section contains the following topics:

Topic Page

Overview of hardware configuration with Profibus DP 32

Description of the application for Profibus DP 34
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MMI terminals to Advantys STB Island with Profibus DP-NIM
Overview of hardware configuration with Profibus DP

Sample 
configuration

The following figure shows the configuration that is described in the application 
example: 

K Connections for the transfer of the configurations and programs

B Connection for the operation of the MMI terminal to Advantys STB Island

990 NAA 263 ••

STB XCA 4002

XBT Z 915

XBT Z 988

Quantum controller with fieldbus master 140 CRP 811 00

PC with configuration software

Fieldbus node
 Advantys STB Island

Magelis XBT PM027010

K B

K

B

K

Profibus DP

1

1/127 2/- - 3/1 4/2 5/3 6/4 7/5 8/- -

NDP 2212

P
D
T 

31
00

A
V
I 
12

70

P
D
T 

31
00

D
D
I 
34

2
0

D
AO

 8
21

0

INPUT

OU TPUT

D C

A

B

A

B

D
D
O

 3
60

0

A

B

D
D
I 
34

2
0

A

B

D
D

O
 3

23
0

A

B
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MMI terminals to Advantys STB Island with Profibus DP-NIM
Required 
components and 
cables

The configuration of the individual nodes, the required configuration software and 
the requirements of the PC are found in chapter  Hardware and software 
requirements, p. 17.

The following table shows the required cable (overview, see section Cable, p. 23):
Cable for configuration and transfer

Cable for operating the application:

Type Meaning

990 NAA 263 20 Modbus connection cable between  PC and CPU of the Quantum

STB XCA 4002 Connection cable between PC and CFG interface of the network 
interface module of the Advantys STB Island

XBT Z915 Connection cable between PC and Magelis XBT PM027010 for the 
transfer of the application

Type Meaning

XBT Z988 Connection cable between the Advantys XBT Island and the 
Magelis XBT PM027010 for operation of the application

Note: 
If the abovementioned XBT cable Z988 is not available, you can also use the 3 
following cables together to operate the Magelis on Advantys STB Island: 
� XBT Z9710
� 990 NAA 263 20 

and
� STB XCA 4002
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MMI terminals to Advantys STB Island with Profibus DP-NIM
Profibus DP cable and connector

Description of the application for Profibus DP

Overview The application describes the possibility of operating a Magelis terminal directly on 
the CFG interface of a network interface module of an Advantys STB Island. Here 
the data should be presented on the Magelis terminal that is sent and received via 
the fieldbus communication as well as data directly from the data image of the 
Advantys STB Island.

Description First the individual steps are described that are necessary to establish fieldbus 
communication between master, Advantys STB Island, and Magelis terminal. Then 
there is a brief presentation of the necessary configuration and programming for the 
fieldbus master and the Magelis terminal.

Type Meaning

KAB PROFIB
Belden 3079A
(for up to 12 Mbit/sec)

Profibus cable (by the meter), Type "A", 02Y (ST) CY 2x0,64 mm2 

490 NAD 911 03 Profibus connector with connection (yellow)

490 NAD 911 04 Profibus connector node (gray)

490 NAD 911 05 Profibus plug node with interface for programming device (gray)

490 NAE 911 00 Profibus TAP

Siemens, BT200 Bus tester

Fa. 3M, 
Order No. 1183 

Foil shielding
Supplier : 3M Deutschland GmbH, Carl-Schurz-Straße 1,
 D-41453 Neuss, Germany

Note: For information about the preparation of the cables and the installation of the 
Profibus DP, see the Quantum PROFIBUS DP manual under Concept, 
840 USE 487 00 in the Installation section.
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MMI terminals to Advantys STB Island with Profibus DP-NIM
3.2 Configuration of an Advantys STB Island with MMI 
connection and Profibus DP network interface

Introduction

Overview This section describes the procedure for configuration of an Island configuration with 
Profibus DP network interface and MMI. For this you use the Advantys configuration 
software.

What's in this 
Section?

This section contains the following topics:

Topic Page

Configuration of the Advantys STB Island with Profibus DP communication 36

Build and download the application in the Island 40
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MMI terminals to Advantys STB Island with Profibus DP-NIM
Configuration of the Advantys STB Island with Profibus DP communication

Overview The following sections provide a brief description of the steps that are necessary for 
configuration of the Advantys STB Island with Profibus DP communication and a 
MMI connection. 
The description is divided into the following sections:
� Setting up the workspace and Island
� Configuring the hardware
� Activating the MMI configuration

Setting up the 
workspace and 
Island

To set up the workspace and Island, proceed as follows:

Step Action

1 Start the Advantys configuration software. 

2 With  File → New Workspace open the New Workspace dialog box.

3 In the Workspace file area and in the Island file area, enter the respective name 
for the new workspace and the Island in the Name field; for the example 
STB_PB1 

4 In the Workspace file area, in the Position field, you can enter the location 
where you would like to store the workspace and Island. For the example, enter: 
LW:\Schneider Application\Advantys_HMI_Profibus_DP.
Note: The data storage location and the file name are displayed in the Name with 
Path text box.

5 Confirm with OK.
Result: The new workspace and the new Island are created.

6 Save the new workspace with File → Save workspace.
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MMI terminals to Advantys STB Island with Profibus DP-NIM
Configuration of 
the hardware

To configure the hardware, proceed as follows:

Step Action

1 In the catalog browser, expand the module type Networking.  

2 Double-click on the module STBNDP2212.
Result: In the Island editor, the network interface module is stored in the position 
all the way to the left.

3 In the catalog browser, expand the module type Power.

4 Double-click on the module STBPDT3100. 
Result: In the Island editor, the module is stored in the next position to the right.

5 Repeat steps 3 (expansion of the required module type) to 4 until you have 
completed your Island configuration in accordance with section Advantys STB 
Island configuration, p. 19.

6 Save the configuration with File → Save Island:STB_PB1.
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MMI terminals to Advantys STB Island with Profibus DP-NIM
Activation of the 
MMI 
communication

To activate the MMI communication, proceed as follows:

Step Action

1 Double-click on the network interface module (NIM) STB NDP 2212
Result: The module editor opens: 

On the General tab you will find details about the configured network interface 
module (NIM) and about the data range lengths for input/output data and for the 
MMI communication. These areas depend on the configured NIM.

STBNDP2212 - V 1.xx Segment: 1 Slot: 1 Node ID: 127 (1/1/127) ?

Module Help

Displays general information about this module type.

OK ApplyCancel

General Parameter I/O Image Diagnostics

Module information

Module name: STBNDP2212
Vendor code: 400005A
Vendor name: Telemecanique
Version: 1.xx

Description:

The STB NDP 2212 is a network interface module for PROFIBUS (standard version).

This module can drive up to 32 I/O modules.

Maximum data image sizes for this module:
  120 words for the sum of input and output (including HMI to PLC and PLC to HMI words)
  120 words HMI to PLC
  120 words for PLC to HMI

Remarks:
At least one I/O module must be present in the Island.

NDP 2212

Profibus DP

Advantys

RUN
PWR

ERR
BUS-FLI

TEST
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MMI terminals to Advantys STB Island with Profibus DP-NIM
2 Change to the Properties tab: 

In the Value column, enter the word count that you would like to reserve in the 
Advantys STB Island for the communication of a Magelis terminal to the fieldbus 
master (HMI to PLC table) and for the communication from the fieldbus master to 
a Magelis terminal (PLC to HMI table). For the example, enter 10 words for each 
communication direction.
Note: For the sample configuration,  (See Advantys STB Island configuration, 
p. 19) a maximum sum of 113 words can be configured for input direction (HMI to 
PLC table) and output direction (PLC to HMI table).

3 Close the module editor by clicking the OK button.

4 Save the parameter input withFile → Save Island:STB_PB1.

Step Action

STBNDP2212 - V 1.xx Segment: 1 Slot: 1 Node ID: 127 (1/1/127) ?

Module Help

Configure object dictionary entries.

OK ApplyCancel

General Parameter I/O Image Diagnostic Hexadecimal

32Max. node ID on the CANopen extension:

Parameter name Value User defined label
NIM Parameters List

Reserved Size (Words) of HMI to PLC table 0
Reserved Size (Words) of  PLC to HMI table 0
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Build and download the application in the Island

Build and 
Download the 
application

To build and download the application, proceed as follows:

Step Action

1 With Island → Build execute the building of the application. If errors are reported 
here (display on the log window), remove these and then rebuild.

2 Under Online → Connection settings → Settings... configure the interface with 
which you would like to connect the Advantys STB Island to the PC (COM1 or 
COM2). 

3 On the NIM STB NDP 2212 set the Profibus DP node address 2: the upper 
rotary switch is set to 0, the lower to 2.

4 Connect the Advantys STB Island to the corresponding PC interface with the 
STB XCA 4002 cable and switch the Advantys STB Island on.

5 Select Online → Connect. 
The Data transfer dialog box opens. 

6 Click the Download button to download your configured application into the 
Island.
Result: The application is downloaded in the Island. The result will appear in the 
log window.

7 Confirm the following query whether the Island should be put into the "running" 
state with OK.
Result: The island is started.
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3.3 Bus configuration for Profibus DP

Introduction

Overview This section contains information concerning the configuration of the Profibus DP 
Master TSX Quantum 140 CRP 811with the SyCon configuration tool.

What's in this 
Section?

This section contains the following topics:

Topic Page

Introduction 42

Provide the GSD and BMP files for Advantys STB Island with Profibus DP 
communication

43

Creating a bus project for Profibus DP 44

Define and configure the master for Profibus DP 46

Configuration of the modular slave Advantys STB Island on Profibus DP 48

Saving and exporting a Profibus DP bus project 54
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MMI terminals to Advantys STB Island with Profibus DP-NIM
Introduction

Overview The bus configuration tool SYC SPU LF• CD28M, called SyCon below, is used to 
configure the PROFIBUS DP network.

Procedure Follow these steps to create and export the bus configuration:

Notes

Note: Included with the SyCon Configurator software are some GSD files for 
PROFIBUS DP Master and Slave modules from Telemecanique and other 
manufacturers. You must still load the GSD file for the modular slave Advantys 
STB Island into the SyCon GSD directory.

Step Action

1 Provide the GSD file for Advantys STB Island

2 Create a bus project

3 Define and configure the master

4 Slave Configuration
� Define and address the slaves and assign them to the corresponding master.
� Configuration of the I/O modules  (This includes empty slots with modular 

slaves)

5 Define bus parameters and save the bus project

6 Export the bus project

Note: The following description concerns the fundamental configuration steps 
only. 
For detailed information, please refer to the online help for the SyCon Configurator 
and the corresponding help files on the installation CD.
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Provide the GSD and BMP files for Advantys STB Island with Profibus DP 
communication

Procedure To provide the GSD file and the associated bitmap files for the modular slave 
Advantys STB Island for the Profibus DP communication, you can proceed in 2 
ways:
� Copying the files with the help of SyCon, p. 43
� Simple copying of the files, p. 44

Copying the files 
with the help of 
SyCon

To copy the GSD file and the associated bitmap files for the modular slave Advantys 
STB Island with the help of Sycon, proceed as follows:

Step Action

1 Place the mini-CD included with the network interface module in the CD drive.

2 Open the bus configuration tool SyCon.

3 Select File → New from the main menu. The Select fieldbus dialog box opens.

4 Select PROFIBUS.

5 Select File → Copy GSD .

6 The Copy GSD  dialog box opens.
Select the drive in which you placed the mini-CD. 

7 Open the directory Device_Profiles  → Profibus_DP. Here you will find the 
required GSD file and three *.dib files.

8 Select the file *.gsd and click the Open button.

9 Answer the question Do you want to import the corresponding bitmap files? 
with Yes.
Result:  Now the *.gsd file and the three *.dib files are loaded into the 
corresponding directory under SyCon.
Result: Now you have all files available in order to configure a Profibus DP 
configuration with the modular slave Advantys STB.
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Simple copying 
of the files

To copy the GSD file and the associated bitmap files for the modular slave Advantys 
STB Island, proceed as follows:

Creating a bus project for Profibus DP

Define target 
directory

First define a target directory for your bus project:

Step Action

1 Place the mini-CD included with the network interface module in the CD drive.

2 Open the directory Device _Profiles  → Profibus_DP. Here you will find the 
required GSD file and three *.dib files.

3 Copy the *.gsd file into the directory LW\...\Sycon\Fieldbus\Profibus\Gsd.

4 Copy the three *.dib files into the directory 
LW\...\Sycon\Fieldbus\Profibus\Bmp.
Result: Now you have all files available in order to configure a Profibus DP 
configuration with the modular slave Advantys STB.

Step Action

1 Open the bus configuration tool SyCon.

2 Select File → New from the main menu.
Result: The Select fieldbus system dialog box opens.

3 Select PROFIBUS.

4 From the main menu select Settings → Path....
Result: The Path  dialog is opened and the path of the SyCon directory is shown 
as the default project directory (e.g. 
C:\Programs\Schneider\Sycon\Project).

5 In the Project directory text box, enter the path of the Concept project directory 
you have already set up, for the example 
LW:\Schneider Application\Advantys_HMI_Profibus_DP\CC_PB1.
Note: The default can also be accepted.
Result: Executing the menu commands  Save  and  Export  (on the main menu 
File ) saves all files into the defined project directory (here your Concept 
directory).
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Creating a bus 
project

This table shows you the steps in setting up a bus project with SyCon. 

Step Action

1 Select File → New from the main menu.
Result: The Select fieldbus  dialog box opens.

2 Select PROFIBUS.
Result: 

3 Select File → Save from the main menu.
Result: The Save as dialog box opens.

4 Now under Filename enter the name for the project (for the example: 
stb_pb1) and confirm with Save.
Result: Your new, still empty project is saved. 

SyCon

File  Edit  View  Insert  Settings  Tools  Window  Help

?
PDD

Press F1 to call help. ConfigurationPROFIBUS
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Define and configure the master for Profibus DP

Define a master This table shows you the steps for defining the Profibus DP master. 

Step Action

1 From the main menu, select  Insert → Master and click the pointer on the 
rectangle at the beginning of the bus line.
Result: You see a list of the available masters: 

2 Select 140 CRP 811 00 and click the Add button and then OK.
Result: The module 140 CRP 811 00 is defined as the bus master.

Insert Master 

Available masters
140 CRP 811 00
TSX PBY 100  Add >>

 Add All >>

<< Remove All 

<< Remove

Selected masters OK

Cancel

Station address
Description

Vendor
Ident number
GSD file name

Schneider Automation GmbH
0x5506
ASA_5506.GSD
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Configuring the 
master

This table shows you the steps for configuring the Profibus DP master. 

Step Action

1 Selecting the Master

2 Select Settings → Master Configuration... from the main menu.
Result: You will see the following dialog box: 

Accept the defaults here.

Master configuration...

General OK

Cancel

Actual Master

Master1

1

Description

Station address

Device 140 CRP 811 00

DP support

DP Master settings...

FMS support
FMS Settings...

Auto-Addressing

CRL...

OD...
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Configuration of the modular slave Advantys STB Island on Profibus DP

Overview The table shows you the sample configuration of the modular Profibus DP slave 
Advantys STB Island:

The following tables show you how the sample configuration is created in the SyCon 
Configurator.

Module Island Bus 
Address

Meaning

STB NDP 2212 127 Network interface module Profibus DP

STB PDT 3100 - 24V power distribution module

STB AVI 1270 1 Analog inputs (2 channels, -10V...+10V), 24 VDC

STB DDI 3420 2 Digital inputs (4 channels), 24 VDC

STB DDO 3600 3 Digital outputs (6 channels), 24 VDC

STB DDI 3420 4 Digital inputs (4 channels), 24 VDC

STB DDO 3230 5 Digital outputs (2 channels), 24 VDC

STB XMP 1100 - Bus termination
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Defining and 
addressing the 
slave module

This table shows you the steps to define a slave module. 

Step Action

1 List the available slave modules with Insert → Slave
Result: 

2 Select the slave STB NDP 2212 and click Add.

3 Check, and if necessary change the Station address, it must match the 
address set by the hardware on the STB NDP 2212.

4 Enter Advantys_Island_2 as Description.

5 Confirm the settings by clicking the OK button.

Insert Slave

Available slaves
170 DNT 110 00
Altivar 38, Altivar 58
Altivar 68
DEA 203
Gateway ATVx8, ATV66 Profibus DP
Lexium 17D
STB NDP 2212
Tego Power APP1 CPF..

  Add >>

 Add All >>

<< Remove All 

<< Remove

Selected slaves

OK

Cancel

Station address
Description

Vendor
Ident number
GSD file name
GSD Revision

Telemecanique
0x0640
SA_0640.GSD
1.0

Slave Filter
 TelemecaniqueVendor

AllSlave type

1/140 CRP 811 00Master
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Configuration of 
the modular 
slave

This table shows you the steps to configure the modular slave: 

Step Action

1 Double-click on the slave Advantys_Island_2.
Result: The Slave configuration dialog box opens. 

Slave Configuration

General
Device

Description

STB NDP 2212
Advantys_Island

Station address 2 OK

Cancel

Parameter Data...

DPV1 Settings...
Activate device in actual configuration
Enable watchdog control  GSD file SA_0640.GSD

Max. length of in-/output data
Max. length of input data
Max. length of output data
Max. number of modules

240 Byte
240 Byte
240 Byte
32

Length of in-/output data
Length of input data
Length of output data
Number of modules

0 Byte
0 Byte
0 Byte
0
Assigned master

Station address 1

Master 1
1/140 CRP 811 00

Actual slave
Station address 2

Slave2
2 / STB NDP 2212

Module IdentifierIn/OutOutputsInputs
STB_DAI_5230 0x41,0x001 byte

STB_DDI_3230 0x41,0x001 byte
STB_DDI_3420 0x41,0x001 byte
STB_DDI_3610 0x41,0x012 byte
STB_DAO_8210 0xC1,0x001 byte1 byte
STB_DDO_3200 0xC1,0x001 byte1 byte
STB_DDO_3230 0xC1,0x001 byte1 byte

Append Module

Remove Module

Insert Module

Predefined Modules

Symbolic  Names 

Slot I Addr.TypeSymbolModuleIdx. I Len. O AddrType O Len.

STB_DAI_7220 0x41,0x001 byte
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2 Configure this modular slave by double-clicking on the corresponding 
modules in accordance with the Advantys STB Island configuration. This is 
then entered in the lower area.
Result:  

Step Action

Slave Configuration

General
Device

Description

STB NDP 2212
Advantys_Island

Station address 2 OK

Cancel

Parameter Data...

DPV1 Settings...
Activate device in actual configuration
Enable watchdog control GSD file SA_0640.GSD

Max. length of in-/output data
Max. length of input data
Max. length of output data
Max. number of modules

240 Byte
240 Byte
240 Byte
32

Length of in-/output data
Length of input data
Length of output data
Number of modules

7 byte
5 byte
2 byte
4

Assigned master
Station address 1

Master 1
1/140 CRP 811 00

Actual slave
Station address 2

Slave2
2 / STB NDP 2212

Module IdentifierIn/OutOutputsInputs
STB_DAI_5230 0x41,0x001 byte

STB_DDI_3230 0x41,0x001 byte
STB_DDI_3420 0x41,0x001 byte
STB_DDI_3610 0x41,0x012 byte
STB_DAO_8210 0xC1,0x001 byte1 byte
STB_DDO_3200 0xC1,0x001 byte1 byte
STB_DDO_3230 0xC1,0x001 byte1 byte

Append Module

Remove Module

Insert Module

Predefined Modules

Symbolic Names

Slot I Addr.TypeSymbolModuleIdx. I Len. O Addr.Type O Len.
1 0IWModule1STB_AVI12701 3
2 6IBModule2STB_DDI34201 1
3 7IBModule3STB_DDO36001 2 0QB 1
4 9IBModule41 1
5 10IBModule5STB_DDO32301 1 1QB 1

STB_DAI_7220 0x41,0x001 byte

STB_DDI3420
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Configuration of 
the MMI 
communication

To configure the MMI communication, proceed as follows:

Step Action

1 Enter the number of HMI output words. To do this, double-click on the 
corresponding entry (HMI output • words) in the list above. This is then 
entered in the lower area.

2 Enter the corresponding number of HMI input words. To do this, double-click 
on the corresponding entry (HMI input • words) in the list above. This is then 
entered in the lower area.
Result:  

3 Confirm the settings with the OK button.

Slave Configuration

General
Device

Description

STB NDP 2212
Advantys_Island

Station address 2 OK

Cancel

Parameter Data...

DPV1 Settings...
Activate device in actual configuration
Enable watchdog control GSD file SA_0640.GSD

Max. length of in-/output data
Max. length of input data
Max. length of output data
Max. number of modules

240 Byte
240 Byte
240 Byte
32

Length of in-/output data
Length of input data
Length of output data
Number of modules

47 Byte
25 Byte
22 Byte
6

Assigned master
Station address 1

Master 1
1/140 CRP 811 00

Actual slave
Station address 2

Slave2
2 / STB NDP 2212

Module IdentifierIn/OutOutputsInputs
HMI output 10 words 0x6910 words

HMI output 12 words 0x6B12
HMI output 13 words 0x6C13
HMI output 14 words 0x6D14
HMI output 15 words 0x6E15
HMI output 16 words 0x6F16
HMI output 32 words 0x6F,0x6F16 words

Append Module

Remove Module

Insert Module

Predefined Modules

Symbolic Names 

Slot I Addr.TypeSymbolModuleIdx. I Len. O Addr.Type O Len.
1 6IBModule2STB_DDI1 1
2 7IBModule3STB_DD1 2 0QB 1
3 9IBModule4STB_DDI1 1
4 10IBModule5STB_DD1 1 1QB 1
5 Module6HMI outp1 2QW 10
6 11IWModule7HMI inpu1 10

HMI output 11 words 0x6A11
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CAUTION

No starting of the Profibus DP

The HMI output and HMI input words must always be entered after the 
Advantys STB Island modules.
Furthermore, the corresponding number of input and output words must 
match precisely the number configured in Advantys STB. Only one 
entry with the precise number has to be made, entries can not be added 
in order to be able to communicate e.g. 20 words.
If this is not the case, the Profibus DP communication with Advantys 
STB Island will not start.

Failure to follow this precaution can result in injury or equipment 
damage.
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Saving and exporting a Profibus DP bus project

Saving the bus 
project

This table shows you the steps to save a Profibus DP bus project in SyCon . 

Step Action

1 Save the bus project with File → Save As...
The following dialog box opens: 

The configuration is stored in the defined directory as a database file *.PB.

Save As

Save

Save in: CC_PB1

?

test.pb

Cancel

File name:

Save as type: PROFIBUS(*.pb)

stb_pb1.pb
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Exporting the 
bus project

This table shows you the ASCII export of the file *.CNF.

Notes on saving The configuration must always be saved as a database file *.PB first, because the 
ASCII file can only be generated from the saved *.PB file. Every change must 
therefore also be saved as a *.PB file before an ASCII file can be generated for the 
export. 
The *.PB and *.CNF files should always be in the same project directory.

PROFIBUS DP 
Configuration in 
Concept

Following the configuration of the PROFIBUS DP nodes in SyCon, the PROFIBUS 
DP configuration has to be imported into the Concept I/O map. For additional 
information, see the section Import of the bus configuration, p. 60.

Step Action

1 Select the master whose configuration you want to export

2 From the main menu, select File → Export → ASCII: 

Result: The configuration is stored in the ASCII file *.CNF within the defined 
directory.

3 Exit the SyCon Configurator.

Save As

Save

Save in: CC_PB1

?

Cancel

File name:

Save as type: CNF-file (*.cnf)

stb_pb1.cnf
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3.4 Configuration using Concept

Introduction

Overview This section contains information concerning the software configuration for the TSX 
Quantum 140 CRP 811 PROFIBUS DP using Concept.

What's in this 
Section?

This section contains the following topics:

Topic Page

Configuration of the CRP 811 57

Import of the bus configuration 60

Master Parameterization and Automatic I/O Address Assignment for 
Profibus DP

63

Master parameters 65
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Configuration of the CRP 811

Enabling the 
Profibus DP

To activare the Profibus DP proceed according to the following steps:

Step Action

1 Start Concept.

2 Open the corresponding Concept project; for the sample project: 
LW:\Schneider Application\Advantys_HMI_Profibus_DP\CC_PB1\

stb_pb1.prj.

3 From the main menu, select Project → Configurator → Config Extensions → 
Select extensions.
Result: The Select extensions  dialog box opens: 

4 From the Profibus DP list box, select the number of the Profibus configurations 
you would like to activate. In the example, select the 1.
Result: The communication module is now listed on the Local Quantum I/O 
station dialog and can be used for I/O map.

Select extensions

OK

TCP/IP-Ethernet: 0Data Protection

Symax-Ethernet: 0Peer Cop

MMS-Ethernet: 0IEC Hot Standby

Profibus DP: 0984 Hot Standby

Cancel Edit
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I/O Map with CRP 
811

To equip the Quantum with the CRP 811, proceed as follows:

Step Action

1 From the main menu, open Project → Configurator the I/O map dialog box.
Result:  The  I/O map  dialog is opened and the first I/O station (Drop) is entered 
into the table automatically.
Result: 

2 Select the line with  Quantum I/O .
Select the command button  Edit.....
Result: You will see the Local Quantum Drop dialog box on which you enter 
the I/O map.

3 Double-click in line 1-10 (rack slot) at the column Module on the text field ....
Result: The  I/O module selection  dialog is opened. 

4 In the Category column, select the category I/OAdapter and then in the 
Modules column the module CRP-811-00. Now click the OK command button.
Result: The 140 CRP 811 module is entered in the I/O map.

I/O Map

Expansion Size:

Cancel HelpOK

144

Drop

1

Head Setup...

Go To Local/Remote (Head Slot ?)

DeleteInsert

Copy Insert

Quantum I/O

Type Holdup (x100ms)

3

In bits

0

Out bits

0

Status Edit

…

Select this row when inserting at end of list

Cut

300050
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Dialog display After defining the I/O map and assigning the references, the dialog box looks as 
follows: 

Importing a 
PROFIBUS DP 
Configuration

The import of the configured Profibus DP nodes is done using the parameter dialog 
for the CRP-811-00. For additional information, see section Import of the bus 
configuration, p. 60.

Bits In:

Local Quantum Drop

Drop

Cancel HelpOK

Module Detected In Ref

CPS-214-00   1-1

Clear

Modules:

Module

0

Copy

Params

Rack-Slot In End

 

Out Ref

 

Out End

 

Description

DC SUMMABLE PS 24V 8A

CPU-x13-0x   1-2    CPU 1xMB+

DDI-353-00  1-3 DC Input 24V 4x8

DDO-353-00   1-4   DC Output 24V 4x8 

AVI-030-00  1-5   Analog Input 8 Ch bipolar 

AVO-020-00  1-6 Analog Output 4 Ch Volt

...  1-7   

...   1-8   

...   1-9  

CRP-811-00      Profibus DP 

...  1-11   

...   1-12  

...   1-13     

...   1-14     

Poll

4

Prev Next

NoneASCII-Port #

Cut PasteDelete

0Bits Out:Bits In:
Bits Out:
Status table:

0
0

1-10

 

100097 100128

000097 000128

400103400100

300108300100
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Import of the bus configuration

Requirement 1. The configuration of the  Profibus DP-nodes was created with the SyCon 
Configurator and exported as *.CNF file.

2. The CRP 811 is enabled and added to the components of a local Quantum I/O 
station.

Bus 
Configuration 
Import 

To import the configuration (*.CNF) into Concept follow these steps:

Note: To guarantee an error free transfer of the PROFIBUS DP configuration make 
sure that sufficient memory is available. To optimize memory allocation, open the 
dialog ( PLC Configuration  →  PLC Memory Partition).

Step Action

1 From the main menu, open Configurator to reach the I/O map dialog.
Result: The  I/O map  dialog is opened and the first I/O station (Drop) is entered 
into the table automatically.

2 Select the line with  Quantum I/O .
Click the command button Edit.....
Result: The module mapping appears.

3 Select the line for the corresponding bus controller (140 CRP 811) from the 
dialog and activate the command button  Params .
Result: The CRP-811-00 (Profibus DP) dialog opens.

4 With the command button Import... you will open the Select source file  
window.

5 Enter the path of the CNF file for importing and press the OK command button.
Result: The PROFIBUS DP configuration is entered in the Concept I/O Map.

6 Assign the modules the appropriate data types.

7 Assign the modules the state RAM addresses. This can be done automatically 
by the system (See Specifying I/O addresses automatically, p. 64) or manually.
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Dialog display After importing the example configuration (see Configuration of the modular slave 
Advantys STB Island on Profibus DP, p. 48) the dialog appears as follows:
Data types and state RAM addresses are already assigned in the representation.

View scrolled to far left: 

Note: Not all data types are always available for the individual I/O modules.

Cut

CRP-811-00 (Profibus DP)

Master

Cancel HelpOK

Delete

Bus Addr: Backplane Slot: 10 Delete

Copy

Params…

Paste

Poll

1

Slave Type In Ref

 2

Bus Adr.

 

STB NDP 2212

 

  

 

  

 

  

 

  

 

Module

2

3 

4

5 

6

 7

 

 

In Type Out Type

Import… Preset ...

Out Ref

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Out End

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In End

 

 

 

 

 

Params…

Slave

UINT16

BOOL

301020 301022

000993 001000

BOOL 100993 101000

BOOL

UINT16

101001 101008

001001 001008

UINT16

101032

1

BOOL 101009 100024

301009301000

BOOL101025BOOL

401000 401009

Add Upload Info
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View scrolled to far right: 

Parameters and 
Default Settings

CRP-811-00 (Profibus DP)

Cancel HelpOK Poll

Out TypeEnd Out Ref

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Out End

 

 

 

 

 

 

 

Diag Type Diag Len

32

 

 

 

 

 

Diag Ref Diag End

Cut

Master

Delete

Bus Addr: Delete

Copy

Params…

Paste

1

Import… Preset ...

Description

 

 

 

 

 

 

HMI output 10 words

Params…

Slave

UINT8 300500 300531

BOOL 001001 001008

BOOL 000993 001000

UINT16 401000 401009

HMI input 10 words

STB_DDO_3600

STB_DDO_3230

STB_DDI_3420

STB_DDI_3420

STB_AVI_1270

Backplane Slot: 10 Add Upload Info

Note: In the Slave area you will find the Params... command button for displaying 
the slave parameters.
In the Master area you will find the Params... command button for displaying and 
editing the master parameters. By activating the Default...  command button the I/
O addresses can be assigned automatically. Both dialogs can be found under 
Master Parameterization and Automatic I/O Address Assignment for Profibus DP, 
p. 63 .
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Master Parameterization and Automatic I/O Address Assignment for 
Profibus DP

Overview The following tables show the procedures to follow in defining the parameters for the 
master and the automatic I/O address assignment.  

Master 
Parameterizing

To define parameters for the master, proceed as follows:

Note: More detailed information on the parameters can be found under Master 
parameters, p. 65

Step Action

1 In the Master area, select the Parameter... command button.
Result: The DP-Master-Params dialog opens.
Dialog display 

2 Adopt the default settings as shown in the figure above or redefine them. 

3 Exit the dialog box with OK. 
Result: You return to the  CRP-811-00 (PROFIBUS DP) dialog.

Cancel HelpOK

DP-Master-Params

1Bus Address

1,5 MBaudBaud rate

100Max. Diag. entries

32Max. Diag. lengths

470Lifesign 3x:
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Specifying I/O 
addresses 
automatically

To automatically define the I/O addresses proceed as follows:

Step Action

1 Select the command button  Preset I/O Mapping.
The Preset dialog opens.
Dialog display 

2 For Input Refs  and Output refs enter 1000. 

3 Exit the dialog box with OK. 
Result: You return to the  CRP-811-00 (PROFIBUS DP)  dialog where the 
defined references are assigned automatically.

Cancel HelpOK

Preset I/O Mapping

Input refs

1x 1

3x 1

I/O assignment
Output refs

0x 1

4x 1

Diag.ref.

3x 500
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Master parameters

Introduction The following is an explanation of the parameters as they are found in the Master 
Parameterizing, p. 63 dialog.  

Bus Address The bus address of the configured PROFIBUS DP master as it was defined in the 
SyCon Configurator is shown in this text field.  

Baud rate The baud rate as it was defined in the SyCon Configurator is shown in this text field. 

Max. Diag. 
Entries

The maximum number of diagnostic data entries made on the PCMCIA card is 
defined in this text field. The default is 100 (10 – 400 valid). 
The value should be greater than 3 times the amount of slaves on the bus.
If the value that is defined here is too low then the master cannot start due to 
diagnosis-buffer-overrun.

Max. Diag. 
Length

The maximum number of diagnostic data bytes per slave that are buffered on the 
PCMCIA board is defined in this text field. The default is 32 (6 – 244 valid). The 
required minimum value is determined by the slave with the greatest number of 
diagnosis bytes. Slaves that exceed this value will not start up. The corresponding 
number of diagnostic bytes can be found in the manufacturer's documentation or the 
device data base.
Max. value entries means: 
All diagnostics data will be received. The amount that is transferred to the PLC 
depends on the addressing however.
The following applies for Schneider slaves:
� Classic TIOs - max. 13 bytes diagnostics data
� Momentum - max. 19 bytes diagnostics data
� DEA203 - max. 22 bytes diagnostics data
� Advantys STB Island - max. 32 bytes diagnostic data

Note: The following rule should be followed due to limited memory on the PCMCIA 
card: Max. Diag. entries x Max. Diag. length < 59520

Note: The following rule should be followed due to limited memory on the PCMCIA 
card: Max. Diag. entries x Max. Diag. length < 59520
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Lifesign This text field defines a 3x address (a word) for the PROFIBUS DP status message.

Bit Status message Meaning

1-13 - No significance

14 0 or 1 No slaves operating on PROFIBUS DP.

Flashing One or more slaves operating on PROFIBUS DP.

15 0 or 1 Not all the slaves are running on the PROFIBUS DP.

Flashing All the slaves are running on the PROFIBUS DP.

16 0 or 1 � CRP 811 has been removed from the backplane
� CRP 811 is faulty.
� Quantum is running on CRP 811 PROFIBUS DP, 

without slaves running.

16 Flashing The CRP 811 runs on the backplane without problems.

  

Note: Diagnostic content is valid only if one slave was active at least one time.

16 15 14 13 12 11 10 9 78 56 4 23 1
MSBLSB
66   11/2004



MMI terminals to Advantys STB Island with Profibus DP-NIM
3.5 Data storage in Advantys and Concept for 
communication with Profibus DP

Introduction

Overview This section contains information about addressing I/O and MMI data in the 
Advantys configuration software and the Concept programming software and about 
the required program parts.

What's in this 
Section?

This section contains the following topics:

Topic Page

Addressing of the I/O modules in Advantys STB and Concept (Profibus DP 
communication)

68

Program description, variable list and section in Concept 75
  11/2004 67



MMI terminals to Advantys STB Island with Profibus DP-NIM
Addressing of the I/O modules in Advantys STB and Concept (Profibus DP 
communication)

Addressing The following overview shows the address assignment for communication with  
Profibus DP in Advantys STB und Concept. 
The address assignment in Advantys STB is done by the system and can be viewed 
under Island → I/O Image Overview → Modbus Image or Island → I/O Image 
Overview → Fieldbus Image.
The corresponding assignment in Concept is configured after import of the I/O 
configuration on the dialog box CRP-811-00 (Profibus DP) (See Dialog display, 
p. 61).
The application configuration of the Magelis terminal with the XBTL1000 
configuration software is based on the addresses in the Modbus format of the 
Advantys configuration software. 

Data mapping in 
Concept

Use the following data types for addressing I/O modules:

I/O module 
type

Favored data type Organization in state RAM

Binary BOOL Bitwise, as a multiple of 16
0x/1x or 3x/4x registers

Analog UINT 16 Wordwise
3x/4x registers

Note: Mapping for a data range (input/output data or status) is not done using byte 
or word-spanning!
Depending on the module type, not all data types are always available.
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Address 
assignment 
overview

For a PROFIBUS DP communication there are a total of 120 words available for the 
sum of the input and output data including the words for MMI communication.

The address assignments for the Input data (Module alignment checkbox for 
Fieldbus Image  activated):

I/O module Addresses in:

Type Type of 
data

Advantys 
STB 
(Modbus 
format)

Advantys STB 
(Fieldbus 
format)

Concept

Occupied Assigned 
range

STB AVI 1270, 
2 analog 
channels

Input data 
channel 1

R 45392, 
Bit 0 ... 15

W1, Bit 0 ... 15 MW 301020 MW 301020 
... 301022

Input data 
channel 2

R 45394, 
Bit 0 ... 15

W2, Bit 0 ... 15 MW 301021

Input status 
channel 1

R 45393, 
Bit 0 ... 7

W3, Bit 8 ... 15 MW 301022, 
Bit 8 ... 15

Input status 
channel 2

R 45395, 
Bit 0 ... 7

W3, Bit 0 ... 7 MW 301022, 
Bit 0 ... 7

STB DDI 3420, 
4 digital input 
channels

Input data 
K1 ... K4

R 45396, 
Bit 0 ... 3

W4, Bit 0 ... 3 MB 100993 - 
100996

MB 100993 - 
101000

Input status 
K1 ... K4

R 45397, 
Bit 0 ... 3

W4, Bit 4 ... 7 MB 100997... 
101000

STB DDO 
3600, 6 digital 
ouput 
channels

Echo 
K1 ... K6

R 45398, 
Bit 0 ... 5

W5, Bit 0 ... 5 MB 101009 - 
101014

MB 101009 - 
101024

Output 
status 
K1 ... K6

R 45399, 
Bit 0 ... 5

W5, Bit 8 ... 13 MB 101017 - 
101022

STB DDI 3420, 
4 digital input 
channels

Input data 
K1 ... K4

R 45500, 
Bit 0 ... 3

W 6, Bit 0 ... 3 MB 101001 - 
101004

MB 101001 - 
101008

Input status 
K1 ... K4

R 45501, 
Bit 0 ... 3

W6, Bit 4 ... 7 MB 101005 - 
101008

STB DDO 
3230, 2 digital 
ouput 
channels

Echo  
K1 ... K2

R 45502, 
Bit 0 ... 1

W7, Bit 0 ... 1 MB 101025 - 
101026

MB 101025 - 
101032

Output 
status 
K1 ... K2

R 45503, 
Bit 0 ... 1

W7, Bit 2 ... 3 MB 101027 - 
101028

HMI to PLC 
table

10 Words R 49488 - 
49497

W 8 ... 17 MW 301000 - 
301009

MW 301000 - 
301009
  11/2004 69



MMI terminals to Advantys STB Island with Profibus DP-NIM
The address assignments for the Output data (Module alignment checkbox for 
Fieldbus Image  activated):

Legend

K
R
W
MW
MB

Channel
Register (Advantys Software, Modbus format)
Word (Advantys Software, Fieldbus format)
Input register (Concept, 3x references)
Coil (Concept, 1x references)

I/O module Addresses in:

Type Type of 
data

Advantys 
STB 
(Modbus 
format)

Advantys STB 
(Fieldbus 
format)

Concept

Occupied Assigned 
range

STB DDO 
3600, 6 digital 
ouput channels

Output data 
K1 ... K6

R 40001, 
Bit 0 ... 5

W1, Bit 0 ... 5 MB 000993 - 
000998

MB 000993 - 
001000

STB DDO 
3230, 2 digital 
ouput channels

Output data 
K1 ... K2

R R40002, 
Bit 0 ... 1

W2, Bit 0 ... 1 MB 001001 - 
001002

MB 001001 - 
001008

PLC to HMI 
table

10 registers R 44097 - 
44106

W 3 ... 12 MW 401000 - 
401009

MW 401000 - 
401009

Legend

K
R
W
MW
MB

Channel
Register (Advantys Software, Modbus format)
Word (Advantys Software, Fieldbus format)
Output register (Concept, 4x references)
Coil (Concept, 0x references)

I/O module Addresses in:

Type Type of 
data

Advantys 
STB 
(Modbus 
format)

Advantys STB 
(Fieldbus 
format)

Concept

Occupied Assigned 
range
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Binary input 
module, data 
type BOOL, 
mapping in 1x 
range

Addressing binary input modules for data type BOOL is done using data mapping in 
the 0x/1x range according to the following illustration: 

Binary input 
module, data 
type BOOL, 
mapping in the 
3x range

Addressing binary input modules for data type BOOL is done using data mapping in 
the 3x/4x range according to the following illustration: 

3 2 1 04...15not used Bit

87654321

4 3 2 1 0

Advantys STB:  binary input module, 4 channels
word n, e.g. 45392: Input Data

Advantys STB:  binary input module, 4 channels
word n+1, e.g. 45393: Input status

Concept: 8 Coil: 1x1 ... 1x8

...15not used Bit

3 2 1 04...15not used Bit

89101112131415

4 3 2 1 0

Advantys STB:  binary input module, 4 channels
word n, e.g. 45392: Input Data

Advantys STB:  binary input module, 4 channels
word n+1, e.g. 45393: Input status

Concept: 1 coil word: 3xn

...15not used Bit

7 ... 0 not used
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Binary output 
module, data 
type BOOL, 
mapping in the  
0x/1x range

Addressing binary output modules for data type BOOL is done using data mapping 
in the 0x/1x range according to the following illustration: 

Binary output 
module, data 
type BOOL, 
mapping in the  
3x/4x range

Addressing binary output modules for data type BOOL is done using data mapping 
in the 3x/4x range according to the following illustration: 

87654321

Advantys STB:  binary output module, 6 channels
word n, e.g. 40001: Output Data

Concept: 8 Coil: 0x1 ... 0x8

3 2 1 045not used Bit 15 … 6

87654321

4 3 2 1 0

Advantys STB:  binary output module, 6 channels
word n, e.g. 445398: Echo of the output data

Advantys STB:  binary output module, 6 channels
word n+1, e.g. 45399: Status of the output data

Concept: 16 Coil: 1x1 ... 1x16

5not used Bit 15 … 6

161514131211109

4 3 2 1 05not used Bit 15 … 6

Advantys STB:  binary output module, 6 channels
word n, e.g. 40001: Output Data

Concept: 1 coil word: 4x1

3 2 1 045not used Bit 15 … 6

89101112131415

4 3 2 1 0

Advantys STB:  binary output module, 6 channels
word n, e.g. 445398: Echo of the output data

Advantys STB:  binary output module, 6 channels
word n+1, e.g. 45399: Status of the output data

Concept: 1 coil word: 3x1

5not used Bit 15 … 6

01234567

3 2 1 07 6 5 415 14 13 12 11 10 9 8

4 3 2 1 05not used Bit 15 … 6
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Analog input 
module, general 
information 
about data 
mapping

Note the following particularities for the data mapping of analog input modules: 

Analog input 
module, data 
type UINT16, 
mapping in the 
3x range

Addressing analog input modules for data type UINT16 is done using data mapping 
in the 3x/4x range according to the following illustration: 

n+1

Input status
channel 1

n+2

Input data
channel 2

n+3

Input status
channel 2

n

Input data
channel 1

0...78...15 0...78...15

m m + 1 m + 2

...1716...98...1 48...4140...3332...2524

0...78...15

Data mapping in  
Advantys 
(Modubs format)

Data mapping
in 
Concept

3 MW

48 MB

Advantys STB:  analog input module, 2 channels, words
n to n+3, e.g. 45392: 45395:

011415 ... 0167 ...011415 ... 0167 ...

n n+ 1n + 2 n + 3

Input data 
channel 1

Input status 
channel 1

Input status 
channel 2

Input data 
channel 2

Concept: 3 coil words: 3xn ... 3xn+2

0...78...15 0...78...15 0...78...15

n n + 1 n + 2
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Analog output 
module, data 
type UINT16, 
mapping in the 
3x/4x range

Addressing analog output modules for data type UINT16 is done using data 
mapping in the 3x/4x range according to the following illustration: 

Advantys STB:  analog output module, 2 channels
word n, n+1, e.g. 40001… 40002: Output Data

Concept: 2 coil words: 4xn, 4xn+1

89101112131415

4 3 2 1 0

Advantys STB:  analog output module, 2 channels
word n, e.g. 45404: Status channel1

Advantys STB:  analog output module, 2 channels
word n+1, e.g. 45405: Status channel2

Concept: 1 coil word: 3xn

5not used Bit 15 … 8

01234567

1415

n
Input data channel 1

8... ...7 01 1415

n + 1
Input data channel 1

8... ...7 01

67 4 3 2 1 05not used Bit 15 … 8 67

1415 8... ...7 01 1415 8... ...7 01

4xn 4xn+1
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Program description, variable list and section in Concept

Overview For the fieldbus master, a counter must be configured whose setpoint and current 
values are sent to the Magelis terminal. The presetting of the setpoint is done using 
the Magelis terminal. The time of day that is available in the fieldbus master must 
also be prepared so that it is displayed on the Magelis terminal.
Furthermore, AND links must be configured that link inputs and outputs of the 
Advantys STB.
The following sections present a brief excerpt from the Concept configuration 
(section and variable list), which is necessary for the creation of the communication 
program.

Variable list The following variables are defined:

For the complete assignment of the registers, see section Address assignment 
overview, p. 69.

Delivery of the 
time

So that the time is available, you must activate the Time of Day checkbox. You will 
find it under Project → Configurator → Specials.
Now in the associated text field enter the register 4x2990 as the first of 8 subsequent 
registers which are thus reserved for time of day.

Variable Name address Data type Comments

reset_ctu 000101 Bool Reset counter

PV_ctu 301000 INT Presetting of the counter setpoint
(specified to the PLC via MMI connected to 
Advantys STB Island)

ctrl_clock 402990 INT Control word for the time of day

weekday 402991 INT Day of the week (1 – 7; 1 = Sunday)

month 402992 INT Month (1-12)

day 402993 INT Day (1 - 31)

year 402994 INT Year (00 – 99)

hour 402995 INT Hours ( 0 – 23)

minute 402996 INT Minutes (0 – 59)

second 402997 INT Seconds (0 – 59)

MW1005 401005 INT Hours (= 402995), presentation on MMI

MW1006 401006 INT Minutes (= 402996), presentation on MMI

MW1007 401007 INT Seconds (= 402997), presentation on MMI
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Extract from the 
section

The following configuration is necessary to support the MMI communication:

Counter with setpoint presetting via the Magelis terminal 

401000 1. Word PLC to HMI 

Linking of inputs/outputs of Advantys STB Island 

Presentation of the time (hours/minutes/seconds) on the Magelis terminal 

FBI_1_1 (2)
CTU

reset_ctu
PV_ctu

.1.4(3)
AND_BOOL

1 reset_ctu

%401000PV

CU
R

CV

Q

FBI_1_3 (1)
SYSCLOCK

%401010TIMER

CLK3
CLK4
CLK5

CLK1
CLK2

FBI_1_1 (2)
CTU

reset_ctu
PV_ctu

.1.4(3)
AND_BOOL

1 reset_ctu

%401000PV

CU
R

CV

Q

FBI_1_3 (1)
SYSCLOCK

%401010TIMER

CLK3
CLK4
CLK5

CLK1
CLK2

.1.5 (4)
AND_BOOL

%100993
%100994

%000993

.1.15 (8)
AND_BOOL

%100995
%100996

%000998

DDI3420 (bus address 2) channels 1 and 2
on 
DDO3600 (bus address 3) channel 1

DDI3420 (bus address 2) channels 3 and 4
on 
DDO3600 (bus address 3) channel 6

.1.12 (6)
MOVE

minute MW1006

.1.13 (7)
MOVE

second MW1007

.1.11 (5)
MOVE

hour MW1005
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3.6 Configuration of a Magelis XBT for connection to 
an Advantys STB Island with Profibus DP network 
interface

Introduction

Overview This section describes the procedure of configuring a Magelis XBT to connect to an 
Advantys STB Island with Profibus DP network interface. For this you use the XBTL 
1000 configuration software.

What's in this 
Section?

This section contains the following topics:

Topic Page

Configuration of the Magelis XBT PM 027010 on network interface module for 
Profibus DP communication

78

Operation of the Magelis XBT PM 027010 82
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Configuration of the Magelis XBT PM 027010 on network interface module for 
Profibus DP communication

Overview The following sections provide a brief description of the steps that are necessary for 
the configuration of the MMI application for Magelis XBT PM 027 010 for connection 
to an Advantys STB Island with a network interface module for Profibus DP.

The description is divided into the following sections:
� Presentation on the application page, p. 79
� Setup of the application page, p. 80
� Configuring the application page, p. 81
� Loading the application, p. 81
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Presentation on 
the application 
page

The following data is presented on the application page:
� Diagnostic data directly from the Island bus data image
� Data that is sent and received via the fieldbus communication

The application page should look as follows: 

Field 1 Display counter current value from master (Concept register 401000)

Field 2 Display setpoint (Concept variable PV_ctu (Concept register 301000))

Field 3 Presetting setpoint for counter in the master (Concept variable PV_ctu)

Fields 4-6 Display time from master (Concept variables MW1005, MW1006, MW1007)

Field 7 Display diagnostic register "network node configuration"(R 45359) of the Advantys 
STB Island

Configuration data for the individual fields:

For the complete assignment of the registers, see section Address assignment 
overview, p. 69.

Field Associated 
variable (40001+i)

Format Access Modbus register in 
Advantys STB

Equipment i Object Type length

1 Master1) 4096 Word Decimal 5 Read 44097 (PLC to HMI)

2 Master1) 9487 Word Decimal 5 Read 49488 (HMI to PLC)

3 Master1) 9487 Word Decimal 5 Write 49488 (HMI to PLC)

4 Master1) 4101 Word Decimal 2 Read 44102 (PLC to HMI)

5 Master1) 4102 Word Decimal 2 Read 44103 (PLC to HMI)

6 Master1) 4103 Word Decimal 2 Read 44104 (PLC to HMI)

7 Master1) 5358 Word Binary 16 Read 45359 (diagnostic STB)

1) Here Master is the default of the XBTL1000 configuration software for the symbol of 
the Modbus slave connected to the Magelis terminal, in this case the Advantys STB 
Island with INTERBUS-NIM. The fieldbus master is not meant here.

C:\Program Files\Schneider Electric\XBT-L1000\APP1_1.DOP - 1:Page 1

Language: ENGLISH*

Counter current value:

Presetting setpoint:

Time:

Diagnosis

Setpoint:

(register 45359)

: :

1 2

3

4 5 6

7
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Setup of the 
application page

To set up the application page, proceed as follows:

Step Action

1 Start the program XBT-L 1000.
Result: The Terminal type configuration dialog box opens.

2 On this dialog box in the Commercial references area, select the terminal type 
XBT-PM027010 by clicking it.

3 On this dialog box in the  Choose Protocol area, select Modbus as the 
communication protocol.

4 Confirm the selection with OK.
Result: The page editor opens with Page 1 : 

5 Under Configuration → Dialogue table, deactivate the Use dialogue table 
checkbox.

6 Save your application with File → Save. The Save As dialog box is displayed. 

7 Specify the place and name under which your application should be saved; for 
the example: 
LW:\Schneider Application\Advantys_HMI_Profius_DP\Magelis_

pb1\xbtl_pb1.dop.
Confirm with the Save command button. 

APP1 – 1:PAGE 1

Language: ENGLISH*
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Configuring the 
application page

To configure the following application page, proceed as follows:

Loading the 
application

To load the application in the Magelis XBT, proceed as follows:

Step Action

1 Place the pointer at the beginning of the second line and enter the text Counter 
Current Value: .

2 Place the pointer in the position of field 1, see section Presentation on the 
application page, p. 79.

3 With Edit → Insert variable field → Alphanumeric, insert the field for 
displaying the current value of the counter.
Result: The Insert an alphanumeric field dialog box opens. 

4 Configure this field in accordance with the details in the table in section 
Presentation on the application page, p. 79.
(You will find the selection for the Access under "Options...").

5 Proceed with the configuration of the other fields 2 - 7 in accordance with the 
presentation of the application page and the table in section Presentation on the 
application page, p. 79 by repeating steps 1 to 4.

Step Action

1 Connect the configured PC interface using the XBTZ915 cable with the Magelis 
XBT PN 027010.

2 Select Send → Export to send your application to the Magelis.
Result: The application is sent to the connected Magelis terminal. 
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Operation of the Magelis XBT PM 027010

Operating the 
application

To operate the application in the Magelis XBT, proceed as follows:

Step Action

1 Make sure that the fieldbus connections are plugged into your configuration and 
that the applications are started in the controller that contains the fieldbus master 
as well as in the Advantys STB Island.

2 Connect the CFG interface of the network interface module of the Advantys STB 
Island using the XBTZ988 cable with the Magelis XBT PM 027010.
Result: The configured application page is displayed on the terminal’s screen. 
Now in the Presetting setpoint field you can specify the setpoint for the counter 
that is configured on the controller connected to the fieldbus.
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Application example for 
connecting an MMI terminal to 
Advantys STB Island with 
INTERBUS-NIM
At a Glance

Introduction In this chapter you will find the application description for the connection of an MMI 
terminal Magelis XBT• to an Advantys STB Island with an INTERBUS network 
interface. 

What's in this 
Chapter?

This chapter contains the following sections:

Section Topic Page

4.1 Application with INTERBUS communication 85

4.2 Configuration of an Advantys STB Island with MMI connection 
and INTERBUS network interface

89

4.3 Bus configuration for INTERBUS 94

4.4 Data storage in Advantys and Concept for communication with 
INTERBUS

104

4.5 Configuration of a Magelis XBT for connection to an Advantys 
STB Island with INTERBUS network interface

114
83
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4.1 Application with INTERBUS communication

Introduction

Overview This section provides a brief overview of the hardware for the INTERBUS 
communication and of the applications.

What's in this 
Section?

This section contains the following topics:

Topic Page

Overview of hardware configuration with INTERBUS 86

Description of the application for INTERBUS 88
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Overview of hardware configuration with INTERBUS

Sample 
configuration

The following figure shows the configuration that is described in the application 
example: 

K Connections for the transfer of the configurations and programs

B Connection for the operation of the MMI terminal to Advantys STB Island

990 NAA 263 ••

STB XCA 4002

XBT Z 915

XBT Z 988

Quantum controller with fieldbus master 140 NOA 622 00

PC with configuration software

Fieldbus node
 Advantys STB Island

Magelis XBT PM027010

K B

K

B

K

INTERBUS

1

1/127 2/-  - 3/1 4/2 5/3 6/4 7/5 8/- -

NDP 2212

P
D
T 

31
00

A
V
I 
12

70

P
D
T 

31
00

D
D
I 
34

2
0

D
AO

 8
21

0

INPUT

OU TPUT

D C

A

B

A

B

D
D
O

 3
60

0

A

B

D
D
I 
34

2
0

A

B

D
D

O
 3

23
0

A

B

About additional
fieldbus nodes
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Required 
components and 
cables

The configuration of the individual nodes, the required configuration software and 
the requirements of the PC are found in chapter  Hardware and software 
requirements, p. 17.

The following table shows the required cable (overview, see section Cable, p. 23):
Cable for configuration and transfer

Cable for operating the application:

Type Meaning

990 NAA 263 20 Modbus connection cable between  PC and CPU of the Quantum

STB XCA 4002 Connection cable between PC and CFG interface of the network 
interface module of the Advantys STB Island

XBT Z915 Connection cable between PC and Magelis XBT PM027010 for the 
transfer of the application

Type Meaning

XBT Z988 Connection cable between the Advantys XBT Island and the 
Magelis XBT PM027010 for operation of the application

Note: 
If the abovementioned XBT cable Z988 is not available, you can also use the 3 
following cables together to operate the Magelis on Advantys STB Island: 
� XBT Z9710
� 990 NAA 263 20 

and
� STB XCA 4002
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INTERBUS cable and connectors

Description of the application for INTERBUS

Overview The application describes the possibility of operating a Magelis terminal directly on 
the CFG interface of a network interface module of an Advantys STB Island. Here 
the data should be presented on the Magelis terminal that is sent and received via 
the fieldbus communication as well as data directly from the data image of the 
Advantys STB Island.

Description First the individual steps are described that are necessary to establish fieldbus 
communication between master, Advantys STB Island, and Magelis terminal. Then 
there is a brief presentation of the necessary configuration and programming for the 
fieldbus master and the Magelis terminal.

Model Order No.

Programming cable for 140 NOA 622 00, 3.7 m (Modbus cable) 990 NAA 263 20

INTERBUS cable, 100 cm 170 MCI 100 00

Remote bus cable 100 m TSX IBSCA 100

Remote bus cable 400 m TSX IBSCA 400

Remote bus cable (by the meter), LiYCY 3x2x0.25 mm2 KAB3225LI

INTERBUS plug set, 9 pin D-SUB, plug plus socket 170 XTS 009 00

Branch interface for remote bus branch, copper cable 170 BNO 671 0x

Interface for DEA station AS BDEA 202

Note: For information about the connection occupation of the cables and the 
installation of the INTERBUS, see the Quantum 140 NOA 622 00, 
840 USE 497 02 user manual and the application manual for the Advantys STB 
Standard-INTERBUS network interface module, 890 USE 174 02.
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4.2 Configuration of an Advantys STB Island with MMI 
connection and INTERBUS network interface

Introduction

Overview This section describes the procedure for configuration of an Island configuration with 
INTERBUS network interface and MMI. For this you use the Advantys configuration 
software.

What's in this 
Section?

This section contains the following topics:

Topic Page

Configuration of the Advantys STB Island mit INTERBUS communication 90

Build and download the application in the Island 93
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Configuration of the Advantys STB Island mit INTERBUS communication

Overview The following sections provide a brief description of the steps that are necessary for 
configuration of the Advantys STB Island with INTERBUS communication and MMI 
connection. 
The description is divided into the following sections:
� Setting up the workspace and Island
� Configuring the hardware
� Activating the MMI configuration

Setting up the 
workspace and 
Island

To set up the workspace and Island, proceed as follows:

Configuration of 
the Hardware

To configure the hardware, proceed as follows:

Step Action

1 Start the Advantys configuration software. 

2 With  File → New Workspace open the New Workspace dialog box.

3 In the Workspace file area and in the Island file area, enter the respective name 
for the new workspace and the Island in the Name field; for the example 
STB_IB1

4 In the Workspace file area, in the Position field, you can enter the location 
where you would like to store the workspace and Island. Accept the default here.
Note: The data storage location and the file name are displayed in the Name with 
Path text box.

5 Confirm with OK.
Result: The new workspace and the new Island are created.

6 Save the new workspace and Island with File → Save workspace.

Step Action

1 In the catalog browser, expand the module type Networking.

2 Double-click on the module STBNIB2212.
Result: In the Island editor, the network interface module is stored in the position 
all the way to the left.

3 In the catalog browser, expand the module type Power.

4 Double-click on the module STBPDT3100. 
Result: In the Island editor, the module is stored in the next position to the right.

5 Repeat steps 3 (expansion of the required module type) to 4 until you have 
completed your Island configuration in accordance with section Advantys STB 
Island configuration, p. 19.

6 Save the configuration with File → Save Island:STB_IB1.
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Activation of the 
MMI 
communication

To activate the MMI communication, proceed as follows:

Step Action

1 Double-click on the network interface module (NIM) STB NIB 2212
Result: The module editor opens: 

On the  General tab you will find details about the configured network interface 
module (NIM) and about the data range lengths for input/output data and for the 
MMI communication. These areas depend on the configured NIM.

STBNIB2212 - V 1.xx Segment: 1 Slot: 1 Node ID: 127 (1/1/127) ?

Module Help

Displays general information about this module type.

OK ApplyCancel

General Parameter I/O Image Diagnostics

Module information

Module name: STBNIB2212

Vendor code: 400005A

Vendor name: Telemecanique

Version: 1.xx

Description:

The STB NIB 2212 is a network interface module for INTERBUS (standard version).

This module can drive up to 32 I/O modules.

Maximum data image sizes for this module are:
  16 words for input (including HMI to PLC words)
  16 words for output (including PLC to HMI words)
  15 words HMI to PLC
  15 words PLC to HMI

Remark:
At least one I/O module must be present in the Island.

NIB 2212

INTERBUS

Advantys

RUN

PWR/UL
ERR

RC
BA

RD
TEST
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2 Change to the Properties tab: 

In the Value column, enter the word count that you would like to reserve in the 
Advantys STB Island for the communication of a Magelis terminal to the fieldbus 
master (HMI to PLC table) and for the communication from the fieldbus master 
to a Magelis terminal (PLC to HMI table). For the example, enter 9 words for each 
communication direction.
Note: For the sample configuration  (See Advantys STB Island configuration, 
p. 19), a maximum of 9 words can be configured for input direction (HMI to PLC 
table) and 14 words in output direction (PLC to HMI table).  

3 Close the module editor by clicking the OK button.

4 Save the parameter input with File → Save Island:STB_IB1.

Step Action

STBNIB2212 - V 1.xx Segment: 1 Slot: 1 Node ID: 127 (1/1/127) ?

Module Help

Configure object dictionary entries.

OK ApplyCancel

General Parameter I/O Image Diagnostics Hexadecimal

32Max. node ID on the CANopen extension:

Parameter name Value User defined label
NIM Parameters Öist

Reserved Size (Words) of HMI to PLC table 0
Reserved Size (Words) of PLC to HMI table 0
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Build and download the application in the Island

Build and 
download the 
application

To build and download the application, proceed as follows:

Step Action

1 With Island → Build execute the building of the application. If errors are reported 
here (display on the log window), remove these and then rebuild.

2 Under Online → Connection settings → Settings... configure the interface with 
which you would like to connect the Advantys STB Island to the PC (COM1 or 
COM2). 

3 Connect the Advantys STB Island to this interface with the STB XCA 4002 cable.

4 Select Online → Connect. 
The Data transfer dialog box opens. 

5 Click the Download button to downoad your configured application to the Island.
Result: The application is downloaded in the Island. The result will appear in the 
log window.

6 Confirm the following query whether the Island should be put into the "running" 
state with OK.
Result: The island is started.
  11/2004 93



MMI terminals on Advantys STB Island with INTERBUS-NIM
4.3 Bus configuration for INTERBUS

Introduction

Overview This section contains information concerning the configuration of the INTERBUS 
Master TSX Quantum 140 NOA 622 00 with the SyCon configuration tool.

What's in this 
Section?

This section contains the following topics:

Topic Page

Introduction 95

Creating the EDS file of the Advantys STB configuration for INTERBUS 96

Startup of the INTERBUS Master 140 NOA 622 00 98
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Introduction

Overview The bus configuration tool SYC SPU LF• CD28M, called SyCon below, is used to 
configure the INTERBUS network. However, SyCon is not started individually, but 
rather called from Concept (See Selection of the INTERBUS in Concept, p. 98).

Procedure Follow these steps to create the bus configuration:

Notes

Note: Included with the SyCon Configurator software are some EDS files for 
INTERBUS Master and Slave modules from Telemecanique and other 
manufacturers. You must still build the EDS file for the modular slave Advantys 
STB Island and load it into the SyCon EDS directory.

Step Action

1 Creating the EDS file of the Advantys STB configuration for INTERBUS, p. 96

2 Copy the EDS file into the corresponding SyCon directory

3 Creating the bus configuration with Concept and SyCon (See Startup of the 
INTERBUS Master 140 NOA 622 00, p. 98)

Note: The following description concerns the fundamental configuration steps 
only. 
For detailed information, please refer to the online help for the SyCon Configurator 
and Concept and the corresponding help files on the installation CD.
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Creating the EDS file of the Advantys STB configuration for INTERBUS

Creating the EDS 
file

You can create the EDS file for the INTERBUS configuration in two ways:
� Configuration-specifically via the Advantys configuration software (See Creating 

the EDS file with Advantys configuration software, p. 96)
or

� with the SyCon (See Creating the EDS file with SyCon, p. 96) EDS Generator 

Creating the EDS 
file with 
Advantys 
configuration 
software

To create the EDS file for the INTERBUS configuration with the Advantys STB 
configuration software, proceed as follows:

Creating the EDS 
file with SyCon

To create the EDS file for the INTERBUS configuration with the SyCon EDS 
Generator, proceed as follows:

Step Action

1 Ensure that the configuration software is not Online → Connected.

2 Select File → Export stb_ib1 .... 
The Export dialog box opens.

3 Under Save enter the path where the EDS file should be saved.
Note: If you specify the directory in which all EDS files for INTERBUS in SyCon 
are stored here (e.g. LW:\...\SyCon\Fieldbus\Interbus\EDS), you do not have to 
copy the file into this directory again with SyCon.

4 Under Filename enter the name of the EDS file; for the example: STB_IB1

5 Click the Save command button.
Result: The Advantys configuration software saves the Island, produces the 
configuration internally, and finally performs the export operation into the EDS 
file.
Note: If an error occurs during saving or production, the export is cancelled. 
Remove the errors and execute another export. Display occurs in the log 
window. 

Step Action

1 Start SyCon and create an INTERBUS project with File → New. 

2 Select Tools → EDS Generator.... 
The EDS Generator dialog box opens.
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3 On the EDS Generator dialog box, enter the following data: 

4 Click the OK command button.
Result: The default dialog box Save file as opens.

5 Here you specify the directory and the name under which the EDS file should be 
saved. 
Accept the preset for the directory. Now enter the desired name (for the example 
STB_IB1.eds) and confirm with Save.
Result: The file is saved in the specified directory and is available directly in 
SyCon if you have accepted the default.

Step Action

EDS generator

analog

PCP capability

Created by Owner name
OK

Cancel

Type

Device class

File information

Device Advantys HMI

Description

Short type Advantys Standard STB

Manufacturer Telemecanique

Configuration

Bitmap

Running

Diagnostic

ADVANTYS_S.BMP

ADVANTYS_R.BMP

ADVANTYS_D.BMP

Layout

digital

Input/output

Output

Process data direction

Input

none

Process data lengths

32 Octet

32 Octet

Input length

Device Configuration

Remote bus branch

Output length

Input type

Output type

IW

QW

Device Identification

51Ident code

Length code

PCP channel

18

0
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Startup of the INTERBUS Master 140 NOA 622 00

Overview The following sections provide a brief description of the steps required for the startup 
and software configuration of the INTERBUS master 140 NOA 622 00.
The steps are divided into the following sections:
� Selection of the INTERBUS in Concept, p. 98
� Evaluating the bus configuration with SyCon, p. 100
� Editing the bus configuration in Concept, p. 101
� Configuration of the 140 NOA 622 00 itself, p. 103

Selection of the 
INTERBUS in 
Concept

Proceed as follows to enter the INTERBUS in Concept for using the 
140 NOA 622 00:

Step Action

1 Open the respective project in Concept.

2 Select Project → Configurator → I/O Map → Go to the entry Generic bus.

3 Click Insert and enter Interbus in the  I/O Handler selection dialog box. 

Select this row, when inserting at end of list.
                0 

O. bits
...                  0

I/O Map

Expansion Size:

 Local/RIO (slot ?)Go To: Copy PasteCut

DeleteInsert

I/O Drop EditStateO. bits

 Local/RIO (slot ?)
 DIO 0 (CPU)
 DIO 1 (slot ?)
 DIO 2 (slot ?)
 Generic bus

1 

Head Setup... OK Cancel Help

 144

IO-Handler selection

Name

OK Cancel Help on Type

Vendor

Interbus Schneider Automation GmbH
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4 Enter the initial addresses for the respective references in the Status box and 
Activate. For additional notes, see the section about Diagnostics and Setup via 
the Generic Bus  in the Quantum 140 NOA 622 00 User guide.

5 Select the desired INTERBUS and continue with Edit...to the dialog box Generic 
Bus Master: Interbus (Board x)

6 Start the SyCon program with Launch cfg for bus configuration (See Evaluating 
the bus configuration with SyCon, p. 100)
Note: 
You can import a bus configuration with the command button Import. Here the 
Bus tables for the Generic Bus are created from scratch by the system. Therefore, 
you must also re-enter all address assignments in Concept even for the 
unchanged bus nodes.
If you make a configuration change in SyCon using the command button Launch 
Cfg, as a rule the address assignments of unchanged INTERBUS nodes are 
retained. However, this must be checked.

Step Action

 Select this row when inserting at end of list
               26 

Holdup
...0

I/O Map

Expansion Size:

 Generic busGo To: Copy PasteCut

DeleteInsert

I/O Drop EditOut bitsIn bits

Head Setup... OK Cancel Help

 144

Type
1  Interbus 300300

Status
400300

Activate
0

Generic Bus Master: Interbus (Board 0)

Settings Params...

Node Description

OK Cancel Help

Slave Mod / Cha

 Master  Slave

Slaves:
Last slave:

0
0

Description:
Status table:
Activate table:

INTERBUS G4 Master NOA622
3:00300 - 3:00506
4:00400 - 4:00324

Prev Next Launch Cfg Import Settings
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Evaluating the 
bus 
configuration 
with SyCon

For evaluating the INTERBUS configuration using the SyCon bus configuration tool, 
proceed as follows:

Step Action

1 There are the following possibilities for evaluating the INTERBUS configuration:
� Read the connected INTERBUS configuration using Online → Automatic 

Network Scan
Note : Select the CIF Serial Driver and assign the appropriate COM interface.
Connect the NOA 622 to the PC (for cable see Hardware requirements, p. 18). 

� Enter the connected INTERBUS configuration
� For converting existing CMD projects of the Generation 4 to SyCon, see 

User’s manual Quantum 140 NOA 622 00 in the section Importing from 
CMD G4 Projects in SyCon.

Note : Further information on this can be found in the SyCon online help or in the 
documentation provided on the SyCon CD.

2 The following figure shows the configuration in SyCon:

3 Save the project and close SyCon.
Result:
The INTERBUS configuration data is accepted by Concept when SyCon is 
closed. The list of nodes is displayed in the dialog box Generic Bus Master: 
Interbus (Board x).

140 NOA 622 00

1.0
stb_ib1

Device

Subscr.No.
Device 1

Master

Advantys_Island_1

INTERBUS

stb_ib1

Generic Bus Master: Interbus (Board 0)

Settings Parameter...

Node Description
 Advantys_Island_10

OK Cancel Help

Slave Baud./Channel

 Master  Slave

Slaves:
Last slave:

1
0

Description:
Status table:
Activate table:

INTERBUS G4 Master as NOA622
3:00001
4:00001

Previous Next Conf. start Import Settings

2/ 2stb_ib1

Generic Bus Master: Interbus (Board 0)

Settings Params...

Node Description
 Advantys_Island_10

OK Cancel Help

Slave Mod / Cha

 Master  Slave

Slaves:
Last slave:

1
0

Description:
Status table:
Activate table:

INTERBUS G4 Master NOA622
3:00001
4:00001

Prev Next Launch Cfg Import Settings

2/ 2
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Editing the bus 
configuration in 
Concept

You must now make the following entries for the INTERBUS configuration in 
Concept:

Step Action

1 Enter State RAM addresses for every IBS slave in Slave → Params... on the 
dialog box Generic Bus Master: Interbus (Board x). You can switch between 
the individual slave nodes in the dialog box Slave Parameter using <<Previous 
and Next>>.

Slave Parameters

OK Cancel Help

Slave

Address:

Name:

Description:

Channel

0

stb_ib1

Advantys_Island_1

<< Prev Next >>

Length [Word]: 16 Settings

Mod / Cha Type In Ref In End Out Ref Out End
1 / 1  BOOL 301001  301016
2 / 1  BOOL 401016 401001
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2 Check, and if necessary change the settings for Timeout and Bus startup 
behavior in the Master area under Settings.

Note:  The Timeout time selected for the NOA 622 must be larger than or equal 
to the CPU Watchdog Timeout to avoid an INTERBUS failure with a program that 
is still running. For larger configurations the CPU Watchdog Timeout and the 
Timeout time for the NOA622 

Step Action

Master's Settings

OK Cancel Help

Cycle for I/O synchronization  General Setting(s)

Name:
Description:

Interbus
INTERBUS G4 Master NOA622

Board No.:
Address:

Free running I/O cycle
Sync. to xfer from/to Master
Sync. for xfer from/to Slave

Timeout

Maximum for
Input or
Output

Bus Startup

No start if slave missing
Start always
Start depending on slave

 300 ms

255

 Word  Dec Hex  Bin

 0

 General Setting(s)
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Configuration of 
the 
140 NOA 622 00 
itself

Proceed as follows for entering the INTERBUS Master:

Step Action

1 Select I/O Map → Go To the entry Local/Remote Head (slot?)

2 In the I/O map for the local backplane under Project → Configurator → I/O map 
→ Edit.... → Module enter module 140 NOA 622 00. 

3 Assign the respective INTERBUS to the corresponding NOA using Params in the 
140-NOA-622-00 parameter dialog box.

4 In the 140-NOA-622-00 parameter dialog box, accept the default values for the 
Output Timeout State and the Bit Orientation Mode.

5 Confirm the settings with OK

140-NOA-622-00

OK Cancel Help

Assignment Master Setup

Set to zero

  NONE
  NONE
 01: Interbus
 : 

Output timeout state

Hold last value

MSB left (IEC)

Bit Orientation Mode

MSB right (984)
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4.4 Data storage in Advantys and Concept for 
communication with INTERBUS

Introduction

Overview This section contains information about addressing I/O and MMI data in the 
Advantys configuration software and the Concept programming software and about 
the required program parts.

What's in this 
Section?

This section contains the following topics:

Topic Page

Addressing in Advantys configuration software and Concept (INTERBUS 
communication)

105

Program description, Variable list and Section in Concept 111
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Addressing in Advantys configuration software and Concept (INTERBUS 
communication)

Addressing The following overview shows the address assignment for the INTERBUS 
communication in Advantys configuration software and Concept. 
The address assignment in the Advantys configuration software is done by the 
system and can be viewed under Island → I/O Image Overview → Modbus Image 
or Island → I/O Image Overview → Fieldbus mage.
The corresponding assignment in Concept is configured after import of the I/O 
configuration on the dialog box Slave parameters (See Editing the bus 
configuration in Concept, p. 101).
The application configuration of the Magelis terminal with the XBTL1000 
configuration software is based on the addresses in the Modbus format of the 
Advantys configuration software. 

Data mapping in 
Concept

During INTERBUS communication, all input data and all output data are stored in 
Concept in sequential input and output registers according to the Fieldbus Image of 
the Advantys configuration software. When addressing the input and output 
registers in Concep

Address modes 
of the 
140 NOA 622 00

The default of the address mode for the fieldbus master is MSB left (IEC). If you 
select another setting here, under some circumstances this can have effects on the 
storage of the I/O data in Concept.
With the mixed Island occupation (digital and analog) shown in the example and with 
a purely analog occupation, the data storage in Concept is independent of the 
address mode of the 140 NOA 622 00 (IEC or 984). 
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Address 
assignment 
overview

You will find the address assignments for the input and output data here. For an 
INTERBUS communication there are a maximum of 16 words input and 16 words 
output data  available (including the words for MMI communication).
The address assignments for the input data:

I/O module Addresses in:

Type Type of 
data

Advantys STB 
(Modbus format)

Advantys STB 
(Fieldbus format)

Concept

STB NIB 2212 Status bit - W 1, Bit 0 ... 15 MW 301001

STB AVI 1270, 
2 analog input 
channels

Input data 
channel 1

R 45392, Bit 0 ... 15 W 2, Bit 0 ... 15 MW 301002

Input status 
channel 1

R 45393, Bit 0 ... 7 W 3, Bit 0 ... 7 MW 301003, 
Bit 0 ... 7

Input data 
channel 2 

R 45394, Bit 0 ... 15 W 4, Bit 0 ... 15 MW 301004

Input status 
channel 2

R 45395, Bit 0 ... 7 W 5, Bit 0 ... 7 MW 301005, 
Bit 0 ... 7

STB DDI 3420, 
4 digital input 
channels

Input data 
K1 ... K4

R 45396, Bit 0 ... 3 W 5, Bit 8 ... 11 MW 301005, 
Bit 8 ... 11

Input status 
K1 ... K4

R 45397, Bit 0 ... 3 W 5, Bit 12 ... 15 MW 301005, 
Bit 12 ... 16

STB DDO 3600, 
6 digital 
output channels

Echo 
K1 ... K6

R 45398, Bit 0 ... 5 W 6, Bit 0 ... 5 MW 301006, bit 
0 .. 5

Output 
status 
K1 ... K6

R 45399, Bit 0 ... 5 W 6, Bit 6 ...11 MW 301006, 
Bit 6 ... 11

STB DDI 3420, 
4 digital input 
channels

Input data 
K1 ... K4

R 45400, Bit 0 ... 3 W 6, Bit 12 ... 15 MW 301006, 
Bit 12 ... 16

Input status 
K1 ... K4

R 45401, Bit 0 ... 3 W 7, Bit 0 ... 3 MW 301007, 
Bit 0 ... 3

STB DDO 3230, 
2 digital output 
channels

Echo 
K1 ... K2 

R 45402, Bit 0 ... 1 W 7, Bit 4 ... 5 MW 301007, 
Bit 4 ... 5

Output 
status 
K1 ... K2

R 45403, Bit 0 ... 1 W 7, Bit 6 ... 7 MW 301007, 
Bit 6 ... 7

HMI to PLC table 9 words R 49488 - 49496 W 8 to 16 MW 301008 ... 
MW 301016
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The address assignments for the output data:

Legend

K
R
W
MW

Channel
Register (Advantys Software, Modbus format)
Word (Advantys Software, Fieldbus format)
Input register (Concept, 3x references)

I/O module Addresses in:

Type Type of 
data

Advantys STB 
(Modbus format)

Advantys STB 
(Fieldbus format)

Concept

STB NIB 2212 Control bit - W 1, Bit 0 ... 15 MW401001

STB DDO 3600, 
6 digital output 
channels

Output 
data 
K1 ... K6

R 40001, Bit 0 ... 5 W 2, Bit 0 ... 5 MW401002, 
Bit 0 ... 5

STB DDO 3230, 
2 digital output 
channels

Output 
data 
K1 ... K2

R 40002, Bit 0 ... 1 W 2, Bit 6 ... 7 MW401002, 
Bit 6 ...7 

PLC to HMI table 9 words R 44097 - 44105 W 3 - 11 MW401003 ... 
MW 401011

Legend

K
R
W
MW

Channel
Register (Advantys Software, Modbus format)
Word (Advantys Software, Fieldbus format)
Output Register (Concept, 4x references)

I/O module Addresses in:

Type Type of 
data

Advantys STB 
(Modbus format)

Advantys STB 
(Fieldbus format)

Concept
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Storage of the 
input data

The following table shows how the 16 words of the input process map of the sample 
configuration (See Advantys STB Island configuration, p. 19) is arranged in the 
Advantys configuration software (Island → I/O Image Overview →  Fieldbus 
Image) as well as in Concept.
Storage in the Advantys configuration software, Fieldbus Image

Input Data

Word Bit

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

1 NIM status word (Sts)

2 Input data channel 1, AVI 1270 (bus address 1)

3 - - - - - - - - Input status channel 1, AVI 1270 (bus address 1)

4 Input data channel 2, AVI 1270 (bus address 1)

5 Input status DDI3420 
(bus address 2)

Input data DDI3420 (bus 
address 2)

Input status channel 2, AVI 1270 (bus address 1)

K4 K3 K2 K1 K4 K3 K2 K1

6 Input data DDI3420 (bus 
address 4)

Output status DDO3600 (bus address 
3)

Echo of the output data DDO3600 (bus 
address 3)

K4 K3 K2 K1 K6 K5 K4 K3 K2 K1 K6 K5 K4 K3 K2 K1

7 - - - - - - - - Output 
status 
DDO3230 
(bus 
address 5)

Echo of the 
output data 
DDO3230 
(bus 
address 5)

Input status DDI3420 
(bus address 4)

K2 K1 K2 K1 K4 K3 K2 K1

8 1st word MMI →PLC communication

9 2nd word MMI →PLC communication

:  :  : :  :   :

15 8th word MMI →PLC communication

16 9th word MMI →PLC communication
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Storage in Concept

Input Data

Word Bit

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

301001 NIM status word (Sts)

301002 Input data channel 1, AVI 1270 (bus address 1)

301003 - - - - - - - - Input status channel 1, AVI 1270 (bus address 1)

301004 Input data channel 2, AVI 1270 (bus address 1)

301005 Input status DDI3420 
(bus address 2)

Input data DDI3420 (bus 
address 2)

Input status channel 2, AVI 1270 (bus address 1)

K4 K3 K2 K1 K4 K3 K2 K1

301006 Input data DDI3420 (bus 
address 4)

Output status DDO3600 (bus address 
3)

Echo of the output data DDO3600 (bus 
address 3)

K4 K3 K2 K1 K6 K5 K4 K3 K2 K1 K6 K5 K4 K3 K2 K1

301007 - - - - - - - - Output 
status 
DDO3230 
(bus 
address 5)

Echo of the 
output data 
DDO3230 
(bus 
address 5)

Input status DDI3420 
(bus address 4)

K2 K1 K2 K1 K4 K3 K2 K1

301008 1st word MMI →PLC communication

301009 2nd word MMI →PLC communication

:  :  : :  :   :

301015 8th word MMI →PLC communication

301016 9th word MMI →PLC communication
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Storage of the 
output data

The following table shows how the 11 words of the output process map of the 
sample configuration (See Advantys STB Island configuration, p. 19) is arranged in 
the Advantys configuration software (Island → I/O Image Overview →  Fieldbus 
Image) as well as in Concept. 
Storage in the Advantys configuration software, Fieldbus Image

Storage in Concept

Output Data

Word Bit

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

1 NIM control word (ctl)

2 - - - - - - - - Output data 
DDO3230 
(bus 
address 5)

Output data DDO3600 
(bus address 3)

K2 K1 K6 K5 K4 K3 K2 K1

3 1st word PLC →MMI communication

4 2nd word PLC →MMI communication

:  :  : :  :  :

10 8th word PLC →MMI communication

11 9th word PLC →MMI communication

Output Data

Word Bit

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

401001 NIM control word (ctl)

401002 - - - - - - - - Output data 
DDO3230 
(bus 
address 5)

Output data DDO3600 
(bus address 3)

K2 K1 K6 K5 K4 K3 K2 K1

401003 1st word PLC →MMI communication

401004 2nd word PLC →MMI communication

:  :  : :  :  :

401010 8th word PLC →MMI communication

401011 9th word PLC →MMI communication
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Program description, Variable list and Section in Concept

Overview For the fieldbus master, a counter must be configured whose setpoint and current 
values are sent to the Magelis terminal. The presetting of the setpoint is done using 
the Magelis terminal. The time of day that is available in the fieldbus master must 
also be prepared so that it is displayed on the Magelis terminal.
Furthermore, AND links must be configured that link inputs and outputs of the 
Advantys STB.
The following sections present a brief excerpt from the Concept configuration 
(section and variable list), which is necessary for the creation of the communication 
program.

Variable list The following variables are defined:

For the complete assignment of the registers, see section Address assignment 
overview, p. 106.

Delivery of the 
time

So that the time is available, you must activate the Time of Day checkbox. You will 
find it under Project → Configurator → Specials.
Now in the associated text field enter the register 4x2990 as the first of 8 subsequent 
registers which are thus reserved for time of day.

Variable Name address Data type Comments

reset_ctu 000101 Bool Reset counter

PV_ctu 301008 INT Presetting of the counter setpoint
(specified to the PLC via MMI connected to 
Advantys STB Island)

ctrl_clock 402990 INT Control word for time of day

weekday 402991 INT Day of the week (1 – 7; 1 = Sunday)

month 402992 INT Month (1-12)

day 402993 INT Day (1 - 31)

year 402994 INT Year (00 – 99)

hour 402995 INT Hours ( 0 – 23)

minute 402996 INT Minutes (0 – 59)

second 402997 INT Seconds (0 – 59)

MW1005 401005 INT Hours (= 402995), presentation on MMI

MW1006 401006 INT Minutes (= 402996), presentation on MMI

MW1007 401007 INT Seconds (= 402997), presentation on MMI
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Excerpt from the 
section

The following configuration is necessary to support the MMI communication:

Counter with setpoint presetting via the Magelis terminal 

401003 1st word PLC to HMI

Linking of inputs/outputs of Advantys STB Island 

301005 5th word input data

401002 2nd word output data

FBI_1_1 (2)

CTU

reset_ctu
PV_ctu

.1.4(3)
AND_BOOL

1 reset_ctu

%401003PV

CU
R

CV

Q

FBI_1_3 (1)

SYSCLOCK

%401010TIMER

CLK3
CLK4
CLK5

CLK1
CLK2

FBI_1_2 (9)

WORD_TO_BIT
%301005 %000500

%000501
%000502
%000503
%000504
%000505
%000506
%000507
%000508
%000509
%000510
%000511
%000512
%000513
%000514
%000515

IN BIT0
BIT1
BIT2
BIT3
BIT4
BIT5
BIT6
BIT7
BIT8
BIT9

BIT10
BIT11
BIT12
BIT13
BIT14
BIT15

FBI_1_4 (10)

BIT_TO_WORD
%000993
%000994
%000995
%000996
%000997
%000998
%000999
%001000
%001001
%001002
%001003
%001004
%001005
%001006
%001007
%001008

BIT0
BIT1
BIT2
BIT3
BIT4
BIT5
BIT6
BIT7
BIT8
BIT9
BIT10
BIT11
BIT12
BIT13
BIT14
BIT15

.1.5 (4)
AND_BOOL

%000508
%000509

%000993

.1.15 (8)
AND_BOOL

%000510
%000511

%000998

%401002OUT

DDI3420 (bus address 2) channels 1 and 2
on 
DDO3600 (bus address 3) channel 1

DDI3420 (bus address 2) channels 3 and 4
on 
DDO3600 (bus address 3) channel 6
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Presentation of the time (hours/minutes/seconds) on the Magelis terminal 

.1.12 (6)
MOVE

minute MW1006

.1.13 (7)
MOVE

second MW1007

.1.11 (5)
MOVE

hour MW1005
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4.5 Configuration of a Magelis XBT for connection to 
an Advantys STB Island with INTERBUS network 
interface

Introduction

Overview This section describes the procedure of configuring a Magelis XBT to connect to an 
Advantys STB Island with INTERBUS network interface. For this you use the XBTL 
1000 configuration software.

What's in this 
Section?

This section contains the following topics:

Topic Page

Configuration of the Magelis XBT PM 027010 on network interface module for 
INTERBUS communication

115

Operation of the Magelis XBT PM 027010 118
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Configuration of the Magelis XBT PM 027010 on network interface module for 
INTERBUS communication

Overview The following sections provide a brief description of the steps that are necessary for 
the configuration of the MMI application for Magelis XBT PM 027 010 for connection 
to an Advantys STB Island with a network interface module for INTERBUS.

The description is divided into the following sections:
� Presentation on the application page, p. 116
� Setup of the application page, p. 117
� Configuring the application page, p. 118
� Loading the application, p. 118
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Presentation on 
the application 
page

The following data is presented on the application page:
� Diagnostic data directly from the Island bus data image
� Data that is sent and received via the fieldbus communication

The application page should look as follows: 

Field 1 Display counter current value from master (Concept register 401003)

Field 2 Display setpoint (Concept variable PV_ctu (register 301008))

Field 3 Presetting setpoint for counter in the master (Concept variable PV_ctu)

Fields 4-6 Display time from the master (Concept variables MW1005, MW1006, MW1007)

Field 7 Display diagnostic register "network node configuration"(R 45359) of the Advantys 
STB Island

Configuration data for the individual fields:

For the complete assignment of the registers, see section Address assignment 
overview, p. 106.

Field Associated 
variable (40001+i)

Format Access Modbus register in 
Advantys STB

Equipment i Object Type length

1 Master1) 4096 Word Decimal 5 Read 44097 (PLC to HMI)

2 Master1) 9487 Word Decimal 5 Read 49488 (HMI to PLC)

3 Master1) 9487 Word Decimal 5 Write 49488 (HMI to PLC)

4 Master1) 4098 Word Decimal 2 Read 44099 (PLC to HMI)

5 Master1) 4099 Word Decimal 2 Read 44100 (PLC to HMI)

6 Master1) 4100 Word Decimal 2 Read 44101 (PLC to HMI)

7 Master1) 5358 Word Binary 16 Read 45359 (diagnostic STB)

1) Here Master is the default of the XBTL1000 configuration software for the symbol of 
the Modbus slave connected to the Magelis terminal, in this case the Advantys STB 
Island with INTERBUS-NIM. The fieldbus master is not meant here.

C:\Program Files\Schneider Electric\XBT-L1000\APP1_1.DOP - 1:Page 1

Language: ENGLISH*

Counter current value:

Presetting setpoint:

Time:

Diagnosis

Setpoint:

(register 45359)

: :

1 2

3

4 5 6

7
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Setup of the 
application page

To set up the application page, proceed as follows:

Step Action

1 Start the program XBT-L 1000.
Result: The Terminal type configuration dialog box opens.

2 On this dialog box in the Commercial References area, select the terminal type 
XBT-PM027010 by clicking it.

3 On this dialog box in the Choose Protocol area, select Modbus as the 
communication protocol.

4 Confirm the selection with OK.
Result: The page editor opens with Page 1 : 

5 Under Configuration → Dialogue table, deactivate the Use dialogue table 
checkbox.

6 Save your application with File → Save. The Save As dialog box is displayed. 

7 Specify the place and name under which your application should be saved; for 
the example: 
LW:\Schneider Application\Advantys_HMI_INTERBUS\Magelis_IB

1\xbtl_ib1.dop.
Confirm with the Save command button. 

APP1 – 1:PAGE 1

Language: ENGLISH*
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Configuring the 
application page

To configure the following application page, proceed as follows:

Loading the 
application

To load the application in the Magelis XBT, proceed as follows:

Operation of the Magelis XBT PM 027010

Operating the 
application

To operate the application in the Magelis XBT, proceed as follows:

Step Action

1 Place the pointer at the beginning of the second line and enter the text Counter 
Current Value: .

2 Place the pointer in the position of field 1, see section Presentation on the 
application page, p. 116.

3 With Edit → Insert variable field → Alphanumeric, insert the field for 
displaying the current value of the counter.
Result: The Insert an alphanumeric field dialog box opens. 

4 Configure this field in accordance with the details in the table in section 
Presentation on the application page, p. 116.
(You will find the selection for the Access under "Options...").

5 Proceed with the configuration of the other fields 2 - 7 in accordance with the 
presentation of the application page and the table in section Presentation on the 
application page, p. 116 by repeating steps 1 to 4.

Step Action

1 Connect the configured PC interface using the XBTZ915 cable with the Magelis 
XBT PN 027010.

2 Select Transfer → Export to send your application to the Magelis.
Result: The application is sent to the connected Magelis terminal. 

Step Action

1 Make sure that the fieldbus connections are plugged into your configuration and 
that the applications are started in the controller that contains the fieldbus master 
as well as in the Advantys STB Island.

2 Connect the CFG interface of the network interface module of the Advantys STB 
Island using the XBTZ988 cable with the Magelis XBT PM 027010.
Result: The configured application page is displayed on the terminal’s screen. 
Now in the Presetting setpoint field you can specify the setpoint for the counter 
that is configured on the controller connected to the fieldbus.
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Application example for 
connecting an MMI terminal to 
Advantys STB Island with 
CANopen NIM 
At a Glance

Introduction In this chapter you will find the application description for the connection of an MMI 
terminal Magelis XBT• to an Advantys STB Island with a CANopen network 
interface. 

What's in this 
Chapter?

This chapter contains the following sections:

Section Topic Page

5.1 Application with CANopen communication 121

5.2 Configuration of an Advantys STB Island with MMI connection 
and CANopen network interface

125

5.3 Bus configuration for CANopen 132

5.4 CANopen configuration under PL7 148

5.5 Data storage in Advantys and PL7f or communication with 
CANopen

153

5.6 Configuration of a Magelis XBT for connection to an Advantys 
STB Island with CANopen network interface

159
119
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5.1 Application with CANopen communication

Introduction

Overview This section provides a brief overview of the hardware for the CANopen 
communication and of the applications.

What's in this 
Section?

This section contains the following topics:

Topic Page

Overview of hardware configuration with CANopen 122

Description of the application for CANopen 124
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Overview of hardware configuration with CANopen

Sample 
configuration

The following figure shows the configuration that is described in the application 
example: 

K Connections for the transfer of the configurations and programs

B Connection for the operation of the MMI terminal to Advantys STB Island

TSX PCX 1031

STB XCA 4002

XBT Z 915

XBT Z 988

Premium controller with fieldbus master TSX CPP 110 and 
associated TAP

PC with configuration software

Fieldbus node
 Advantys STB Island

Magelis XBT PM027010
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Required 
components and 
cables

The configuration of the individual nodes, the required configuration software and 
the requirements of the PC are found in chapter  Hardware and software 
requirements, p. 17.

The following table shows the required cable (overview, see section Cable, p. 23):
Cable for configuration and transfer

Cable for operating the application:

Type Meaning

TSX PCX 1031 Multifunctional communication cable between PC and CPU of the 
Premium

STB XCA 4002 Connection cable between PC and CFG interface of the network 
interface module of the Advantys STB Island

XBT Z915 Connection cable between PC and Magelis XBT PM027010 for the 
transfer of the application

Type Meaning

XBT Z988 Connection cable between the Advantys XBT Island and the 
Magelis XBT PM027010 for operation of the application

Note: 
If the abovementioned XBT cable Z988 is not available, you can also use the 3 
following cables together to operate the Magelis on Advantys STB Island: 
� XBT Z9710
� 990 NAA 263 20 

and
� STB XCA 4002
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Cable and connectors for the CANopen bus
For CANopen there are no pre-converted cables available; for this special 
connectors and cables are available on the market. The performance capability of 
the CANopen bus depends on the type of cable used.
The following components have been used for this sample configuration:

The CANopen connectors have screw clamps and must be connected as follows by 
the user:

Description of the application for CANopen

Overview The application describes the possibility of operating a Magelis terminal directly on 
the CFG interface of a network interface module of an Advantys STB Island. Here 
the data should be presented on the Magelis terminal that is sent and received via 
the fieldbus communication as well as data directly from the data image of the 
Advantys STB Island.

Description First the individual steps are described that are necessary to establish fieldbus 
communication between master, Advantys STB Island, and Magelis terminal. Then 
there is a brief presentation of the necessary configuration and programming for the 
fieldbus master and the Magelis terminal.

Model Supplier Order No.

Data cable DCA 701 for CANopen,

 2x2x0.22mm2, twisted pair, shielded

Selectron
www.selectron.ch

44170014

CANopen connector with bus termination (connect to 
TAP and Advantys NCO 2212 or the last bus node)

Erni
www.erni.com

103643

Standard CANopen connector without bus termination 103668

PIN Signal Description

2 CAN_L CAN bus low

3 CAN_GND CAN bus reference (ground)

7 CAN_H CAN bus high

D-sub, 9-pin, connector 

1 2 3 4 5

6 7 8 9

occupied
unused

Shield (for the connector)

CAN_L (Pin 2)
CAN_H (Pin 7)

CAN_GND (Pin 3)
not connected
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5.2 Configuration of an Advantys STB Island with MMI 
connection and CANopen network interface

Introduction

Overview This section describes the procedure for configuration of an Island configuration with 
CANopen network interface and MMI. For this you use the Advantys configuration 
software.

What's in this 
Section?

This section contains the following topics:

Topic Page

Configuration of the Advantys STB Island with CANopen communication 126

Setting the bus parameters, build and download the application in the Island 130
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Configuration of the Advantys STB Island with CANopen communication

Overview The following sections provide a brief description of the steps that are necessary for 
configuration of the Advantys STB Island with CANopen communication and MMI 
connection. 
The description is divided into the following sections:
� Setting up the workspace and Island
� Configuring the hardware
� Activating the MMI configuration

Setting up the 
workspace and 
Island.

To set up the workspace and Island, proceed as follows:

Step Action

1 Start the Advantys configuration software. 

2 With  File → New Workspace open the New Workspace dialog box.

3 In the Workspace file area and in the Island file area, enter the respective name 
for the new workspace and the Island in the Name field; for the example: 
STB_CO1:

4 In the Workspace file area, in the Position field, you can enter the location 
where you would like to store the workspace and Island. Accept the default here.
Note: The data storage location and the file name are displayed in the Name with 
Path text box.

5 Confirm with OK.
Result: The new workspace and the new Island are created.

6 Save the new workspace with File → Save workspace.
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Configuration of 
the hardware

To configure the hardware, proceed as follows:

Step Action

1 In the catalog browser, expand the module type Networking.

2 Double-click on the module STBNCO2212.
Result: In the Island editor, the network interface module is stored in the position 
all the way to the left.

3 In the catalog browser, expand the module type Power.

4 Double-click on the module STBPDT3100. 
Result: In the Island editor, the module is stored in the next position to the right.

5 Repeat steps 3 (expansion of the required module type) to 4 until you have 
completed your Island configuration in accordance with section Advantys STB 
Island configuration, p. 19.

6 Save the configuration with File → Save Island:STB_CO1.
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Activation of the 
MMI 
communication

To activate the MMI communication, proceed as follows:

Step Action

1 Double-click on the network interface module (NIM) STB NCO 2212
Result: The module editor opens: 

On the  General tab you will find details about the configured network interface 
module (NIM) and about the data range lengths for input/output data and for the 
MMI communication. These areas depend on the configured NIM.

STBNCO2212 - V 1.xx Segment: 1 Slot: 1 Node ID: 127 (1/1/127) ?

Module Help

Displays general information about this module type.

OK ApplyCancel

General Parameter I/O Image Diagnostics

Module information

Module name: STBNCO2212

Vendor code: 400005A

Vendor name: Telemecanique

Version: 1.xx

Description:

The STB NCO 2212 is a network interface module for CANopen (standard version).

This module can drive up to 32 I/O modules.

Maximum data image sizes for this module are:
 120 words input (including HMI to PLC words)
 120 words output (including PLC to HMI words)
 120 words HMI to PLC
 120 words PLC to HMI

Remarks:
At least one I/O module must be present in the Island.
For this NIM, the number of drives (profile 402) attached to the Extender is limited to 7.

NCO 2212

CANopen

Advantys

RUN
PWR

ERR
CAN ERR
CAN RUN

TEST
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2 Change to the Properties tab: 

In the Value column, enter the word count that you would like to reserve in the 
Advantys STB Island for the communication of a Magelis terminal to the fieldbus 
master (HMI to PLC table) and for the communication from the fieldbus master 
to a Magelis terminal (PLC to HMI table). For the example, enter 10 words for 
each communication direction.
Note: For the sample configuration  (See Advantys STB Island configuration, 
p. 19) , a maximum of 114 words can be configured for input direction (HMI to 
PLC table) and 119 words in output direction (PLC to HMI table).  

3 Close the module editor by clicking the OK button.

4 Save the parameter input with File → Save Island:STB_CO1.

Step Action

C H A N G E!

STBNCO2212 - V 1.xx Segment: 1 slot: 1 Node ID: 127 (1/1/127) ?

Module Help

Configure object dictionary entries.

OK ApplyCancel

General Parameter I/O Image Diagnostics Hexadecimal

32Max. node ID on the CANopen extension:

Parameter name Value User defined label
NIM Parameters List

Reserved Size (Words) of HMI to PLC table 0
Reserved Size (Words) of PLC to HMI table 0
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Setting the bus parameters, build and download the application in the Island

Setting the baud 
rate

The Baud rate is set with the two rotary switches on the front side of the NIM. To do 
this, proceed as follows:

Setting of the 
network node 
address

The network node addressis also set with the two rotary switches on the front side 
of the NIM. To do this, proceed as follows:

Step Action

1 Bring the power down on the Advantys STB Island.

2 With a small screwdriver, set the bottom rotary switch (ONES) in the range 
Baudrate (to any position after 9).

3 With a small screwdriver, set the upper rotary switch (TENS) to position 4 (250k 
bits).

4 Switch the Advantys STB Island on so that the baud rate setting is taken over.
Note: The baud rate setting is only taken over if the lower rotary switch is in the 
Baud rate area and the voltage is switched on.

Step Action

1 Bring the power down on the Advantys STB Island.

2 With a small screwdriver, set the upper rotary switch (TENS) to position 0.

3 With a small screwdriver, set the lower rotary switch (ONES) to position 2. This 
corresponds to the network node address 2 on the CANopen bus, which must be 
taken into account during the bus configuration with SyCon.

4 Switch the Advantys STB Island on so that the network node address is taken 
over.
Note: The address setting and a change of the setting are only taken over when 
voltage is switched on. 
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Build and 
download the 
application

To build and load the application, proceed as follows:

Step Action

1 With Island → Build execute the building of the application. If errors are reported 
here (display on the log window), remove these and then rebuild.

2 Under Online → Connection settings → Settings... configure the interface with 
which you would like to connect the Advantys STB Island to the PC (COM1 or 
COM2). 

3 Connect the Advantys STB Island to this interface with the STB XCA 4002 cable.

4 Select Online → Connect. 
The Data transfer dialog box opens. 

5 Click the Download button to download your configured application into the 
Island.
Result: The application is downloaded in the Island. The result will appear in the 
log window.

6 Confirm the following query whether the Island should be put into the "running" 
state with OK.
Result: The island is started.
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5.3 Bus configuration for CANopen

Introduction

Overview This section contains information concerning the configuration of the CANopen 
Master Premium TSX CPP 110 with the SyCon configuration tool.

What's in this 
Section?

This section contains the following topics:

Topic Page

Introduction 133

Creating the EDS file of the Advantys STB configuration for CANopen 134

Create a CANopen bus project 135

Defining the CANopen master and configuring the bus 137

Configuration of the modular slave Advantys STB Island on CANopen 139

Saving the CANopen bus project 147
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Introduction

Overview The bus configuration tool SYC SPU LF• CD28M, called SyCon below, is used to 
configure the CANopen network.

Procedure Follow these steps to create and export the bus configuration:

Notes

Note: Included with the SyCon Configurator software are some EDS files for 
CANopen Master and Slave modules from Telemecanique and other 
manufacturers. You must still build the EDS file for the modular slave Advantys 
STB Island and load it into the corresponding SyCon EDS directory.

Step Action

1 Creating the EDS file of the Advantys STB configuration for CANopen, p. 134

2 Loading the EDS file into the corresponding SyCon directory

3 Create a bus project

4 Define and configure the master

5 Slave Configuration
� Defining and addressing the slave
� Configuration of the PDOs

6 Define bus parameters and save the bus project

Note: The following description concerns the fundamental configuration steps 
only.
For detailed information, please refer to the online help for the SyCon Configurator 
and PL7 and the corresponding help files on the installation CD.
  11/2004 133



MMI terminal on Advantys STB Island with CANopen- NIM
Creating the EDS file of the Advantys STB configuration for CANopen

Creating the EDS 
file with 
Advantys 
configuration 
software

To create the EDS file for the CANopen configuration with the Advantys STB 
configuration software, proceed as follows after configuring the hardware:

Step Action

1 Ensure that the configuration software is not Online → Connected. 

2 Select File → Export stb_co1.... 
The Export dialog box opens.

3 Under Save enter the path where the EDS file should be saved.
Note: If you specify the directory in which all EDS files for CANopen in SyCon 
are stored here (e.g. LW:\...\SyCon\Fieldbus\CANopen\EDS), you do not have 
to copy the file into this directory again with SyCon.

4 Under Filename enter the name of the EDS file; for the example: STB_CO1:

5 Click the Save command button.
Result: The Advantys configuration software saves the Island, produces the 
configuration internally, and finally performs the export operation into the EDS 
file.
Note If an error occurs during saving or building, the export is cancelled. 
Remove the errors and execute another export. Display occurs in the log 
window.
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Create a CANopen bus project

Define target 
directory

First define a target directory for your bus project:

Step Action

1 Open the bus configuration tool SyCon either directly or from PL7.
To open from PL7, on the Premium PL7 configuration window of the TSX 
CPP110 card, click the tool button

   
Result: The SyCon tool appears in the window.

2 From the main menu select Settings → Path....
Result: The Path  dialog is opened and the path of the SyCon directory is shown 
as the default project directory (e.g. 
C:\Programs\Schneider\Sycon\Project).

3 In the Project directory text box, enter the path of the PL7 project directory you 
have already set up, for the example 
C:\Schneider Application\Advantys_HMI_CANopen\PL7_CO1.
Note: The default can also be used.
Result: Executing the menu commands  Save  and  Export  (on the main menu 
File ) saves all files into the defined project directory (here your PL7 directory).

hilscher
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Create a bus 
project

This table shows you the steps in setting up a bus project with SyCon. 

Step Action

1 From the main menu, select the File → New command
Result: The Select fieldbus  dialog box opens. 

2 Select CANopen and confirm with Ok.
Result: An empty structure appears in the window. 

3 Select File → Save from the main menu.
Result: The Save as dialog box opens.

4 Now under Filename enter the name for the project (for the example stb_co1) 
and confirm with Save.
Result: Your new, still-empty project is saved. 

Select  fieldbus 

CANopen
InterBus
PROFIBUS

OK

Cancel

SyCon

File  Edit  View  Paste  Online  Settings  Window  Help

?

Press F1 to call help. ConfigurationCANopen
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Defining the CANopen master and configuring the bus 

This table shows you the steps for defining the CANopen master: 

Configuration of 
the bus

The table shows you the various steps for configuring the CANopen bus: 

Step Action

1 Select the Insert → Master command
Result:The following dialog box opens: 

2 � Select TSX CPP 110,
� Click Add,
� Enter a master module name in the Description field,

Annotations: The name may contain neither empty spaces nor special 
characters and is limited to a maximum of 32 characters.

� Confirm with Ok.
Result: The following structure appears: 

Insert Master 

Available devices
TSX CPP 100
TSX CPP 110  Add >>

 Add all >>

<<Remove

<<Remove all

Selected devices OK

Cancel

Node ID (address)

Description

C
IF --

CANopen_MasterCAN

Master TSX CPP 110
Node ID 1Node ID 

Step Action

1 Selecting the CANopen master TSX CPP 110.
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2 Select the command Settings →  Bus Parameter....
Result: The following window appears: 

3 Configure:
� the speed to 250 kbit/s

Note: This value must correspond to the hardware setting on the Advantys 
hardware STB NCO 2212.

� the value of SYNC COB-ID to 128 (default value),
� the period time to 100 ms (default).

4 Select Disabled for Master stops in case of node guard or heartbeat error 
occurs.

5 Select Enabled for Heartbeat function.

6 As Master producer heartbeat time select 200 ms (default). 

7 Select Enable global start node.

8 Confirm with Ok.

Step Action

Bus Parameter

disabled enabled

Enable Global Start Node

Master Node ID 1 OK

CancelBaudrate 1 Mbit/s

Master stops in case of Node Guard or Heartbeat Error 

Synchronization object (SYNC)

COB-ID 128

Communication Cycle Period 100 msec.

Heartbeat function

Master producer heartbeat time 200 msec.

Enable

29-Bit Selection entries

Acceptance code 00 Hex

Enable 29 Bit Selector

00 00 00

28 ... ... 0 Bit

Acceptance mask 00 Hex00 00 00
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Configuration of the modular slave Advantys STB Island on CANopen

Overview The table shows you the sample configuration of the modular CANopen slave 
Advantys STB Island:

The node-specific EDS file was produced from this sample configuration with the 
Advantys configuration software, see Creating the EDS file with Advantys 
configuration software, p. 134. The following tables show you how to create the 
slave configuration in SyCon.

Module Island Bus 
Address

Meaning

STB NCO 2212 127 CANopen network interface module

STB PDT 3100 - 24Vpower distribution module

STB AVI 1270 1 Analog inputs (2 channels, -10V...+10V), 24 VDC

STB DDI 3420 2 Digital inputs (4 channels), 24 VDC

STB DDO 3600 3 Digital outputs (6 channels), 24 VDC

STB DDI 3420 4 Digital inputs (4 channels), 24 VDC

STB DDO 3230 5 Digital outputs (2 channels), 24 VDC

STB XMP 1100 - Bus termination
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Defining and 
addressing the 
node

This table shows you the steps in defining a node. 

Step Action

1 List the available nodes with Insert → Node.
Result: 

2 Select the device STB_CO1 and click Add.

3 Check, and if necessary change the Node ID, it must match the address set 
by the hardware on the STB NCO 2212. In the example, Node ID 2 is set.

4 Enter Advantys_Island as Description.

5 Confirm the settings by clicking the OK button.
Result: The following structure appears: 

Insert Node

Available devices

 Add >>

 Add all >>

<<Remove

<<Remove all

Selected devices

OK

Cancel

Node ID

Description

Node filter
Vendor

profile

Telemecanique

All

Vendor name

Product number

Telemecanique

0x33001546
Product version No report
Product revision

EDS file name

No report

STB_CO1.EDS
EDS Revision 0

ATV58_E
ATV58_F
ATV58F_E
ATV58F_F
LEXIUM17D
STB_CO1
STB NCO 2212

C
IF

 --CAN

Master TSX CPP 11

Advantys_Island_2

Master

Node ID 2
Node STB_CO1

Node ID 1
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Configuration of 
the PDO for the 
node

The table shows you the various steps for configuring the slave 
Advantys_Island_2:

Step Action

1 Double-click on the slave Advantys_Island_2.
Result: The following window appears: 

Node configuration

Node

Description

STB_CO1

Advantys_Island_2

NodeID (address) 2 OK

Cancel

Node BootUp

OPC objectsActivate node in actual configuration

Automatic COB-ID allocation in accordance with profile 301

Actual node

2 / STB_CO1

PDO Contents Mapping…

PDO characteristics…

Define new Receive PDO…

Define new Transmit PDO…

PDO Name I Len.I Addr.I TypeCOB-IDSymbolic Name O Type O Len.O Addr.

Object
Configuration

File Name STB_CO1.EDS

Configuration Error
Control Protocol

Emergency COB-ID 130
Nodeguard COB-ID 1794

Device Profile 401 Device type Analog Input, Digital Output, Digital Input

Predefined Process Data Objects (PDOs) from EDS file

PDO mapping method

DS301 V4

Add to configured PDOs

Obj.Idx. PDO Name
1400 RxPDO1_Communication Parameter
1401 RxPDO2_Communication Parameter
1402 RxPDO3_Communication Parameter
1403 RxPDO4_Communication Parameter
1800 TxPDO1_Communication Parameter
1801 TxPDO2_Communication Parameter

Configured PDOs

Delete configured PDO

Symbolic Names
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2 Select the first pre-defined object Receive- PDO 1400 RxPD01Commmunication Parameter and click 
the Add to configured PDOs button.
Result: The following window appears: 

3 Accept the defaults and confirm with OK .

Step Action

Node receive PDO characteristics, master output process data

node shall use a synchronization message to actuate the receive PDO.
receive PDO transmission Triggering Mode dependent

OKTransmission Mode

node shall use every 10 received synchronization message to actuate the received PDO

receive PDO transmission Triggering Mode dependent only

Receive PDO transmission event is defined in the device profile

Resulting CANopen specific transmission type 255

event driven, PDO transmitted when data has changed

Triggering Mode

cyclic transmission every 10 node cycle interval (inhibit time)

receive PDO transmission Triggering Mode dependent
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4 Repeat the steps 1 to 3 for all PDOs that are displayed in the range Predefined process data objects 
(PDOs) from EDS file.
Note: You must configure all listed PDOs from the range Predefined process data objects (PDOs) 
from EDS file. You are not allowed to change the configuration and mapping of the PDOs, otherwise 
the I/O assignment in PL7 will no longer match the I/O assignment of the Advantys configuration 
software.
Result: The following window appears: 

Caution: When adding the fifth Transmit PDO TxPDO05 you will see a message indicating that no 
standard COB-ID is available. You must absolutely change the COB-ID entered automatically by hand, 
see step 5 to step 6.
There is an explanation of the individual PDOs in the section Process data objects, p. 145.

5 Remove the checkmark in the Automatic COB-ID allocation according to CANopen profile 301 
checkbox.

Step Action

Node configuration

Node

Description

STB_CO1

Advantys_Island_2

Node ID (address) 2 OK

Cancel

Node BootUp

OPC objectsActivate node in actual configuration

Automatic COB-ID allocation in accordance with Profile 301

Actaul node
2 / STB_CO1

PDO Contents Mapping…

PDO characteristics…

Define new Receive PDO…

Def.ine new Transmit PDO…

PDO Name I Len.I Addr.I TypeCOB-IDSymbolic Name O Type O Len.O Addr.
RxPDO01 514PDO_1400 QB 10
RxPDO02 770PDO_1401 QB 80
RxPDO03 1026PDO_1402 QB 80
RxPDO04 1282PDO_1403 QB 40
TxPDO01 70IB386PDO_1800
TxPDO02 40IB642PDO_1801

Object
Configuration

File Name STB_CO1.EDS

Configuration Error
Control Protocol

Emergency COB-ID 130
Nodeguard COB-ID 1794

Device Profile 401 Device type Analog Input, Digital Output, Digital Input

Predefined Process Data Objects (PDOs) from EDS file

PDO mapping method

DS301 V4

Add to configured PDOs

Obj.Idx. PDO Name
1400 RxPDO1_Communication Parameter
1401 RxPDO2_Communication Parameter
1402 RxPDO3_Communication Parameter
1403 RxPDO4_Communication Parameter
1800 TxPDO1_Communication Parameter
1801 TxPDO2_Communication Parameter

Configured PDOs

Delete configured PDO

Symbolic Names
TxPDO03 80IB898PDO_1802
TxPDO04 80IB1154PDO_1803
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6 For the fifth configured transmit PDO TxPDO05, delete the COB-ID that was entered automatically in the 
COB-ID column (here 2028) and enter the free COB-ID 1664.

7 To release the transmission of analog input signals, click the Object configuration button on the Node 
configuration dialog box.
Result: The Object configuration dialog box opens.

8 Double-click in the Predefined supported objects in the EDS file area on the Obj.Idx 6423 (Analogue 
Input Global Interrupt Enable).
Result: The associated elements are displayed in the lower area Configured objects automatically-
written while Node startup sequence.
Result: The following window appears: 

9 For Analogue Input Global Interrupt Enable under Choosen Value  enter 1.

10 Confirm the object configuration window by clicking OK.

11 Confirm the node configuration window by clicking OK.

Step Action

Object configuration

Node

Description

STB_CO1

Advantys_Island_2

Node ID 2 OK

Cancel

Access Filter

All

Obj.Idx. PDO dialogChoosen valueParameterSub.Idx.
1A04         X220800102 byte special input object1
1A04         X220900102 byte special input object2
6423 0Analogue Input Global Interrupt Enable0

Add to Configured Objects

 Configured Objects automatically written while Node startup sequence

Delete Configured Object

Decimal:

Obj.Idx. AccessDefault Value:ParameterSub.Idx.
read only(no default value)Analog Input Block No.22

Predefined supported Objects in the EDS file
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Process data 
objects

The following Process data objects are required for the sample configuration:

PDO COB-ID Type Adr. Length 
(in bytes)

Explanation

RxPDO1 514 QB 0 1 Binary output data

RxPDO2 770 QB 1 8 SPS -> HMI communication 

RxPDO3 1026 QB 5 8 SPS -> HMI communication 

RxPDO4 1282 QB 9 4 SPS -> HMI communication 

TxPDO1 386 IB 0 7 Binary input data, status of the analog 
and binary inputs as well as status 
and echo of the binary outputs

TxPDO2 642 IB 4 4 Analog input data

TxPDO3 898 IB 6 8 HMI -> SPS communication 

TxPDO4 1154 IB 10 8 HMI -> SPS communication 

TxPDO5 1664 IB 14 4 HMI -> SPS communication 

Legend

RxPDO Receive PDO: PDO is sent by the fieldbus master and received by the 
CANopen slave Advantys STB Island.

TxPDO Transmit PDO (send): PDO is sent by the slave Advantys STB Island and 
received by the fieldbus master.
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Assignment to the Advantys output data (PDO alignment checkbox activated):

Assignment to the Advantys input data (PDO alignment checkbox activated):

For the complete assignment of the registers, see Address assignment overview, 
p. 155 section.

PDO Length 
(in bytes)

Advantys fieldbus 
image

Explanation

RxPDO1 1 W1 Binary output data

RxPDO2 8 W 2... 5 SPS -> HMI communication 

RxPDO3 8 W 6 ... 9 SPS -> HMI communication 

RxPDO4 4 W 10 ... 11 SPS -> HMI communication 

PDO Length 
(in bytes)

Advantys fieldbus 
image

Explanation

TxPDO1 7 W 1 ... 4 Binary input data, status of the analog and 
binary inputs as well as status and echo of 
the binary outputs

TxPDO2 4 W 5 ... 6 Analog input data

TxPDO3 8 W 7 ... 10 HMI -> SPS communication 

TxPDO4 8 W 11 ... 14 HMI -> SPS communication 

TxPDO5 4 W 15 ... 16 HMI -> SPS communication 
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Saving the CANopen bus project

Saving the Bus 
Project

This table shows you the steps to save a CANopen bus project in SyCon . 

CANopen 
configuration in 
PL7

After configuration of the CANopen nodes in SyCon, the CANopen must be imported 
in PL7. For additional information, see the section Configuration of the CANopen 
connection, p. 150.

Step Action

1 Save the bus project with File → Save As...
Result: The configuration is stored in the defined directory as a CANopen file 
*.co.
Result: 

With the *.co file, all data is available that is required by PL7 for additional 
configuration.

Save As

Save

Save in: Project

?

test.co

Cancel

File name:

Save as type: CANopen(*.co)

STB_CO1.co
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5.4 CANopen configuration under PL7

Introduction

Overview This section contains information concerning the software configuration for the TSX 
Premium TSX 572623 with CANopen master TSX CPP 110 under PL7.

What's in this 
Section?

This section contains the following topics:

Topic Page

Configuration of the CANopen master 149

Starting CANopen communication 152
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Configuration of the CANopen master

How to proceed To configure the CANopen communication with PL7 proceed as follows:
� Configuration of the CANopen master TSX CPP 110 (See Configuration of the 

master, p. 149)
� Configuration of the CANopen connection, p. 150

Configuration of 
the master

With the following steps you configure a TSX CPP 110 card in the Type III PCMCIA 
slot of the processor as CANopen master:

Step Action

1 Open the hardware configuration editor in the application browser.

2 Open the configuration window of the processor communication channel by 
double-clicking on the Comm area of the processor.

3 Select the communication channel CHANNEL 1 from the drop-down menu.
Example: 

4 From the drop-down menu select the PCMCIA card TSX CPP 100-110:
Example: 

Result: The configuration window (See Configuration of the CANopen 
connection, p. 150) for the CANopen bus is displayed.

CHANNEL 1

(connection not configured)

 CHANNEL 1:

CHANNEL 0
CHANNEL 1

(No PCMCIA submodule)

MAST

CHANNEL 1
 CHANNEL 1

(No PCMCIA submodule)

(connection not configured) MASTTSX FPP 200 FIPWAY-PCMCIA CARD
TSX FPP 10 FIPIO-PCMCIA CARD
TSX MBP 100 MODBUS+-PCMCIA CARD
TSX MDM 10 MODEM-PCMCIA CARD
TSX SCP 111 RS232 OPEN-PCMCIA CARD
TSX SCP 114 RS485 OPEN-PCMCIA CARD
TSX CPP 100-110 CANOPEN-PCMCIA CARD
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Configuration of 
the CANopen 
connection

On the CANopen configuration window, make the declaration of the communication 
channel and configure the parameters of a CANopen connection:  

CHANNEL 1
 Channel 1:

Designation: PROCESSOR TSX P 57253

TSX CPP 100-110 CANOPEN-PCMCIA CARD

CANopen MAST

Configuration

SyConPL7

 Bus start up Inputs  Outputs

 Configuration load mode

Automatic
Semi-automatic (bus alone)
By program

Maintain RAZ

Transmission speed
SYNC Message COB-ID
SYNC Message Period
Auto-Clear

Select database

Bus Configuration

32

301

hilscher

No. of words (%MW)

Index of 1st %MW
32

401

No. of words (%MW)

Index of 1st %MW

1

2
3

5

4 7

9

Configuration size                       1329          words

 SyCon tool

Watchdog

Activated

Disactived

C:\Schneider Application\Advantys_HMI_CANo

250 kBit/s

128
100 ms

0

6

10

8
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The following settings are required:

Number Function

1 Accept the default MAST, that is, the MAST task serves as the update interval 
of the storage areas linked with the I/O.

2 Accept the default Automatic as the bus start behavior.

3 Specify the behavior of the outputs on stopping of the bus: Maintain or RAZ 
(default)

4 Click the Select database command button to import the file STB_CO1.co in 
PL7. For the example, select: 
LW:\Schneider Application\Advantys_HMI_CANopen\PL7_CO1\stb

_co1.co

5 A number of 32 words is set. For the inputs as Index of the 1.%MW enter the 
value 301.

6 A number of 32 words is set. For the outputs as Index of the 1.%MW enter the 
value 401.

7 Accept the default Activated for the watchdog of the CANopen bus: The 
watchdog is triggered if the PCMCIA card cannot manage the bus correctly 
anymore, the outputs of the slaves are then set to null.

8 Accept the default PL7: The CANopen configuration is loaded together with the 
PL7 application into the PLC.

9 This button enables the start of the Sycon software if this software is installed on 
the PC.

10 If you click the Bus configuration command button, you get an overview of the 
CANopen bus configuration with the parameters of all configured nodes.
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Starting CANopen communication

How to proceed To start the CANopen configuration, you must carry out the following steps:
� Save the PL7 application
� Upload the application and the CANopen configuration in PLC

Saving the PL7 
application

Proceed as follows to finish the application:

Loading the PL7 
application

To load the application in the Premium PLC, proceed as follows:

Step Action

1 Confirm the entries for the bus configuration and close the hardware 
configuration window.

2 After selecting Program → MAST-Task → Sections create the necessary 
program for the application with Edit → Create  (see Program description, 
variable list and sections in PL7, p. 157) .

3 Confirm the settings and save the application with File → Save.

Step Action

1 Connect the programming device to your Premium PLC using a TSX PCX 1031 
cable.

2 Select PLC → Connect.
Result: A connection between the programming device and the PLC is 
established. 

3 Select PLC → Transfer program.
Result: The Program transfer dialog box opens. 

4 Select PC -> PLC and confirm with OK.
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5.5 Data storage in Advantys and PL7f or 
communication with CANopen

Introduction

Overview This section contains information about addressing I/O and MMI data in the 
Advantys configuration software and the PL7 programming software and about the 
required program parts.

What's in this 
Section?

This section contains the following topics:

Topic Page

Addressing in Advantys STB and PL7 (CANopen communication) 154

Program description, variable list and sections in PL7 157
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Addressing in Advantys STB and PL7 (CANopen communication)

Addressing The following overview shows the address assignment for communication with  
CANopen in Advantys STB und PL7. 
The address assignment in Advantys STB is done by the system and can be viewed 
under Island → I/O Image Overview → Modbus Image or Island → I/O Image 
Overview → Fieldbus Image.
The corresponding assignment in PL7 is configured after import of the I/O 
configuration on the Configuration window.
The application configuration of the Magelis terminal with the XBTL1000 
configuration software is based on the addresses in the Modbus format of the 
Advantys configuration software. 

Data storage in 
PL7

During the CANopen communication all input data and all output data is stored in 
sequential input and output words in PL7.
If in the Advantys configuration software on the I/O Image Overview → Fieldbus 
map tab you have activated the PDO alignment checkbox, you will see the display 
of the input and output data as it is also displayed in PL7.
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Address 
assignment 
overview

You will find the address assignments for the input and output data here. For a 
CANopen communication there are a maximum of 120 words input and 120 words 
output data available (including the words for MMI communication).
The address assignments for the input data:

I/O module Addresses in:

Type Type of 
data

Advantys STB 
(Modbus format)

Advantys STB 
(Fieldbus format)

PL7

STB AVI 1270, 
2 analog input 
channels

Input status 
channel 1

R 45393, Bit 0 ... 7 W 1, Bit 0 ... 7 %MW301, 
Bit 0 ... 7

Input status 
channel 2

R 45395, Bit 0 ... 7 W 1, Bit 8 ... 15 %MW301, 
Bit 8 ... 15

STB DDI 3420, 
4 digital input 
channels

Input data 
K1 ... K4

R 45396, Bit 0 ... 3 W 2, Bit 0 ... 3 %MW302, 
Bit 0 ... 3

Input status 
K1 ... K4

R 45397, Bit 0 ... 3 W 2, Bit 4 ... 7 %MW302, 
Bit 4 ... 7

STB DDO 3600, 
6 digital output 
channels

Echo 
K1 ... K6 

R 45398, Bit 0 ... 5 W 2, Bit 8 ... 13 %MW302, 
Bit 8 ... 13

Output 
status 
K1 ... K6

R 45399, Bit 0 ... 5 W 3, Bit 0 ...5 %MW303, 
Bit 0 ... 5

STB DDI 3420, 
4 digital input 
channels

Input data 
K1 ... K4

R 45400, Bit 0 ... 3 W 3, Bit 8 ... 11 %MW303, 
Bit 8 ... 11

Input status 
K1 ... K4

R 45401, Bit 0 ... 3 W 3, Bit 12 ... 15 %MW303, 
Bit 12 ... 15

STB DDO 3230, 
2 digital output 
channels

Echo 
K1 ... K2 

R 45402, Bit 0 ... 1 W 4, Bit 0 ... 1 %MW304, 
Bit 0 ... 1

Output 
status 
K1 ... K2

R 45403, Bit 0 ... 1 W 4, Bit 2 ... 3 %MW304, 
Bit 2 ... 3

STB AVI 1270, 
2 analog input 
channels

Input data 
channel 
1K1 ... K4

R 45392, Bit 0 ... 15 W 5, Bit 0 ... 15) %MW305, 
Bit 0 ... 15

Input data 
channel 
2K1 ... K4

R 45394, Bit 0 ... 15 W 6, Bit 0 ... 15 %MW306, 
Bit 0 ... 15

HMI to PLC table 10 words R 49488 - 49497 W 7 to 16 %MW 307 
... 316
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The address assignments for the output data:

Legend

K
R
W
%MW

Channel
Register (Advantys Software, Modbus format)
Word (Advantys Software, Fieldbus format)
Word (inputs, PL7)

I/O module Addresses in:

Type Type of 
data

Advantys STB 
(Modbus format)

Advantys STB 
(Fieldbus format)

PL7

STB DDO 3600, 
6 digital output 
channels

Output 
data 
K1 ... K6

R 40001, Bit 0 ... 5 W 1, Bit 0 ... 5 %MW 401, 
Bit 0 ... 5

STB DDO 3230, 
2 digital output 
channels

Output 
data 
K1 ... K6

R 40002, Bit 0 ... 1 W 1, Bit 6 ... 7 %MW 401, 
Bit 6 ... 7

PLC to HMI table 10 words R 44097 - 44106 W 2 - 11 %MW 402 
... 411

Legend

K
R
W
%MW

Channel
Register (Advantys Software, Modbus format)
Word (Advantys Software, Fieldbus format)
Word (outputs, PL7)

I/O module Addresses in:

Type Type of 
data

Advantys STB 
(Modbus format)

Advantys STB 
(Fieldbus format)

PL7
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Program description, variable list and sections in PL7

Overview For the fieldbus master, a counter must be configured whose setpoint and current 
values are sent to the Magelis terminal. The presetting of the setpoint is done using 
the Magelis terminal. The time that is available in the fieldbus master must also be 
prepared so that it is displayed on the Magelis terminal.
Furthermore, AND links must be configured that link inputs and outputs of the 
Advantys STB.
The following sections present a brief excerpt from the PL7 configuration (sections 
and variable list), which is necessary for the creation of the communication program.

Variable list The following variables are defined:

For the complete assignment of the registers, see section Address assignment 
overview, p. 155.

Symbol address Data type Comments

Counter_Clock %M5 EBOOL Count tick

Counter_Value %MW402 WORD Counter current value

PV_ctu %MW307 WORD Presetting of the counter setpoint
(specified to PLC via MMI connected to 
Advantys STB Island)

Hour %MW407 WORD Hours: Presentation on MMI

Minute %MW408 WORD Minutes: Presentation on MMI

Second %MW409 WORD Seconds: Presentation on MMI
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Excerpt from the 
sections

The following configuration is necessary to support the MMI communication:
stb_co_count: Counter with setpoint presetting via the Magelis terminal 

%MW307 1st word HMI to PLC table (counter setpoint)

%MW402 1st word PLC to HMI table (counter current value)

stb_co_and: 
Linking of inputs/outputs of Advantys STB Island 

stb_co_time:
Presentation of the time (hours/minutes/seconds) on the Magelis terminal 

OPERATE

%S5 %M5

%MW402:=%MW402+1

OPERATE

%MW402:=0

COMPARE

%MW402>=%MW307

%M5
P

%MW302:X0 %MW401:X0%MW302:X1

%MW401:X5%MW302:X02 %MW302:X3

DDI3420 (bus address 2) channels 1 and 2 on DDO3600 (bus address 3) channel 1

DDI3420 (bus address 2) channels 3 and 4 on DDO3600 (bus address 3) channel 6

!  (* Sekunden %MW409 *)
   %MW50:=ROL(%SW50,8);
   %MW409:=BCD_TO_INT(%MW50);

   (* Minuten %MW408 *)
   %MW51:=%SW51 AND 16#00FF;
   %MW408:=BCD_TO_INT(%MW51);

   (* Stunden %MW407 *)
   %MW52:=%SW51 AND 16#FF00;
   %MW53:=ROL(%MW52,8);
   %MW407:=BCD_TO_INT(%MW53);
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5.6 Configuration of a Magelis XBT for connection to 
an Advantys STB Island with CANopen network 
interface

Introduction

Overview This section describes the procedure of configuring of a Magelis XBT to connect to 
an Advantys STB Island with CANopen network interface. For this you use the XBTL 
1000 configuration software.

What's in this 
Section?

This section contains the following topics:

Topic Page

Configuration of the Magelis XBT PM 027010 on network interface module for 
CANopen communication

160

Operation of the Magelis XBT PM 027010 164
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Configuration of the Magelis XBT PM 027010 on network interface module for 
CANopen communication

Overview The following sections provide a brief description of the steps that are necessary for 
the configuration of the MMI application for Magelis XBT PM 027 010 for connection 
to an Advantys STB Island with a network interface module for CANopen.

The description is divided into the following sections:
� Presentation on the application page, p. 161
� Setup of the application page, p. 162
� Configuring the application page, p. 163
� Loading the application, p. 163
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Presentation on 
the application 
page

The following data is presented on the application page:
� Diagnostic data directly from the Island bus data image
� Data that is sent and received via the fieldbus communication

The application page should look as follows: 

Field 1 Display counter current value from master (PL7 variable Counter_Value)

Field 2 Display counter setpoint from master (PL7 variable PV_ctu)

Field 3 Presetting setpoint for counter in the master (PL7 variable PV_ctu)

Fields 4-6 Display time from master (PL7 variables hour, minute and second)

Field 7 Display diagnostic register "network node configuration"(R 45359) of the Advantys 
STB Island

Configuration data for the individual fields:

For the complete assignment of the registers, see section Address assignment 
overview, p. 155.

Field Associated 
variable (40001+i)

Format Access 
type

Modbus register in 
Advantys STB

Equipment i Object Type length

1 Master1) 4096 Word Decimal 5 Read 44097 (PLC to HMI)

2 Master1) 9487 Word Decimal 5 Read 49488 (HMI to PLC)

3 Master1) 9487 Word Decimal 5 Write 49488 (HMI to PLC)

4 Master1) 4101 Word Decimal 2 Read 44102 (PLC to HMI)

5 Master1) 4102 Word Decimal 2 Read 44103 (PLC to HMI)

6 Master1) 4103 Word Decimal 2 Read 44104 (PLC to HMI)

7 Master1) 5358 Word Binary 16 Read 45359 (diagnostic STB)

1) Here Master is the default of the XBTL1000 configuration software for the symbol of 
the Modbus slave connected to the Magelis terminal, in this case the Advantys STB 
Island with CANopen NIM. The fieldbus master is not meant here.

C:\Program Files\Schneider Electric\XBT-L1000\APP1_1.DOP - 1:Page 1

Language: ENGLISH*

Counter current value:

Presetting setpoint:

Time:

Diagnosis

Setpoint:

(register 45359)

: :

1 2

3

4 5 6

7
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Setup of the 
application page

To set up the application page, proceed as follows:

Step Action

1 Start the program XBT-L 1000.
Result: The Terminal type configuration dialog box opens.

2 On this dialog box in the  Commercial reference area, select the terminal type 
XBT-PM027010 by clicking it.

3 On this dialog box in the Choose Protocol area, select Modbus as the 
communication protocol.

4 Confirm the selection with OK.
Result: The page editor opens with Page 1 : 

5 Under Configuration → Dialogue table, deactivate the Use dialogue table 
checkbox.

6 Save your application with File → Save. The Save As dialog box is displayed. 

7 Specify the place and name under which your application should be saved; for 
the example: 
LW:\Schneider Application\Advantys_HMI_CANopen\Magelis_co1

\xbtl_co1.dop.
Confirm with the Save command button. 

APP1 – 1:PAGE 1
Language: ENGLISH*
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Configuring the 
application page

To configure the following application page, proceed as follows:

Loading the 
application

To load the application in the Magelis XBT, proceed as follows:

Step Action

1 Place the pointer at the beginning of the second line and enter the text Counter 
Current Value: .

2 Place the pointer in the position of field 1, see section Presentation on the 
application page, p. 161.

3 With Edit → Insert variable field → Alphanumeric, insert the field for 
displaying the current value of the counter.
Result: The Insert an alphanumeric field dialog box opens. 

4 Configure this field in accordance with the details in the table in section 
Presentation on the application page, p. 161.
(You will find the selection for the Access under "Options...").

5 Proceed with the configuration of the other fields 2 - 7 in accordance with the 
presentation of the application page and the table in section Presentation on the 
application page, p. 161 by repeating steps 1 to 4.

Step Action

1 Connect the configured PC interface using the XBTZ915 cable with the Magelis 
XBT PN 027010.

2 Select Transmit → Export to send your application to the Magelis.
Result: The application is sent to the connected Magelis terminal. 
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Operation of the Magelis XBT PM 027010

Operating the 
application

To operate the application in the Magelis XBT, proceed as follows:

Step Action

1 Make sure that the fieldbus connections are plugged into your configuration and 
that the applications are started in the controller that contains the fieldbus master 
as well as in the Advantys STB Island.

2 Connect the CFG interface of the network interface module of the Advantys STB 
Island using the XBTZ988 cable with the Magelis XBT PM 027010.
Result: The configured application page is displayed on the terminal’s screen. 
Now in the Presetting setpoint field you can specify the setpoint for the counter 
that is configured on the controller connected to the fieldbus.
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Glossary
analog input A module that contains circuits that convert analog DC input signals to digital values 
that can be manipulated by the processor. By implication, these analog inputs are 
usually direct—i.e., a data table value directly reflects the analog signal value.

analog output A module that contains circuits that transmit an analog DC signal proportional to a 
digital value input to the module from the processor. By implication, these analog 
outputs are usually direct—i.e., a data table value directly controls the analog signal 
value.

application 
object

In CAN-based networks, application objects represent device-specific functionality, 
such as the state of input or output data.

CAN controller area network. The CAN protocol (ISO 11898) for serial bus networks is 
designed for the interconnection of smart devices (from multiple manufacturers) in 
smart systems for real-time industrial applications. CAN multi-master systems 
ensure high data integrity through the implementation of broadcast messaging and 
advanced error mechanisms. Originally developed for use in automobiles, CAN is 
now used in a variety of industrial automation control environments.

CANopen 
protocol

An open industry standard protocol used on the internal communication bus. The 
protocol allows the connection of any standard CANopen device to the island bus.

A

C
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Glossary
CFG port The configuration interface on the network interface module (NIM) of an Advantys 
STB Island serves to connect a computer with the Advantys configuration software 
or to connect an MMI terminal.

COB communication object. A communication object is a unit of transportation (a 
message) in a CAN-based network. Communication objects indicate a particular 
functionality in a device. They are specified in the CANopen communication profile.

configuration The arrangement and interconnection of hardware components within a system and 
the hardware and software selections that determine the operating characteristics of 
the system.

digital I/O An input or output that has an individual circuit connection at the module 
corresponding directly to a data table bit or word that stores the value of the signal 
at that I/O circuit. It allows the control logic to have discrete access to the I/O values.

EDS electronic data sheet. The EDS is a standardized ASCII file that contains information 
about a network device’s communications functionality and the contents of its object 
dictionary. The EDS also defines device-specific and manufacturer-specific objects.

Fieldbus format The data in the process data image is displayed in the respective format of the 
fieldbus protocol used. This is determined by the type of NIM used.

D

E

F
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Glossary
GSD generic slave data (file). A device description file, supplied by the device’s 
manufacturer, that defines a device’s functionality on a Profibus DP network.

HMI human-machine interface (man machine interface (MMI)). A usually graphic user 
interface for industrial devices.

INTERBUS 
protocol

The INTERBUS fieldbus protocol observes a master/slave network model with an 
active ring topology, having all devices integrated in a closed transmission path.

LSB least significant bit, least significant byte. The part of a number, address, or field that 
is written as the rightmost single value in conventional hexadecimal or binary 
notation.

master/slave 
model

The direction of control in a network that implements the master/slave model is 
always from the master to the slave devices.

MMI man machine interface (human-machine interface (HMI)) A usually graphic user 
interface for industrial devices.
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Modbus Modbus is an application layer messaging protocol. Modbus provides client and 
server communications between devices connected on different types of buses or 
networks. Modbus offers many services specified by function codes.

Modbus format The data in the process data map is displayed as it is exchanged within the physical 
island and with the MMI via the Island bus. 

MSB most significant bit, most significant byte. The part of a number, address, or field that 
is written as the leftmost single value in conventional hexadecimal or binary notation.

NIM network interface module. This module is the interface between an island bus and 
the fieldbus network of which the island is a part. A NIM enables all the I/O on the 
island to be treated as a single node on the fieldbus. The NIM also provides 5 V of 
logic power to the Advantys STB I/O modules in the same segment as the NIM.

Object 
Dictionary

Also called the Object directory. Part of the CANopen device model that provides a 
map to the internal structure of CANopen devices (according to CANopen profile 
DS-401). A device’s object dictionary is a lookup table that describes the data types, 
communications objects, and application objects the device uses. By accessing a 
particular device’s object dictionary through the CANopen fieldbus, you can predict 
its network behavior and build a distributed application.

PDM power distribution module. A module that distributes either AC or DC field power to 
a cluster of I/O modules directly to its right on the island bus. A PDM delivers field 
power to the input modules and the output modules. It is important that all the I/O 
clustered directly to the right of a PDM be in the same voltage group—either 
24 VDC, 115 VAC, or 230 VAC.
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PDO process data object. In CAN-based networks, PDOs are transmitted as unconfirmed 
broadcast messages or sent from a producer device to a consumer device. The 
transmit PDO from the producer device has a specific identifier that corresponds to 
the receive PDO of the consumer devices.

PE protective earth. A return line across the bus for fault currents generated at a sensor 
or actuator device in the control system.

PLC programmable logic controller. The PLC is the brain of an industrial manufacturing 
process. It automates a process as opposed to relay control systems. PLCs are 
computers suited to survive the harsh conditions of the industrial environment.

Profibus DP Profibus decentralized peripheral. An open bus system that uses an electrical 
network based on a shielded two-wire line or an optical network based on a fiber-
optic cable. DP transmission allows for high-speed, cyclic exchange of data between 
the controller CPU and the distributed I/O devices.

Repeater An interconnection device that extends the permissible length of a bus.

Rx reception. For example, in a CAN-based network, a PDO is described as an RxPDO 
of the device that receives it.

SDO Service data object. In CAN-based networks, SDO messages are used by the 
fieldbus master to access (read/write) the object directories of network nodes.

STB Smart Terminal Block

SyCon SYstem CONfigurator is software for configuring fieldbuses.
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Tx transmission. For example, in a CAN-based network, a PDO is described as a 
TxPDO of the device that transmits it.

watchdog timer A timer that monitors a cyclical process and is cleared at the conclusion of each 
cycle. If the watchdog runs past its programmed time period, it generates a fault.
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I/O module on Profibus DP, 68
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Bit allocation BOOL

Bin. I module, 1x Range, 71
Bin. I module, 3x range, 71
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Bin. O module, 3x/4x range, 72

Bit allocation UINT16
Analog I module, 3x range, 73
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Advantys STB (MMI) configuration, 128
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Bus configuration procedure, 133
Configuration under PL7, 148
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Configuring connection in PL7, 150
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Configuring node (SyCon), 140
Configuring PDO (SyCon), 141
Create bus project, 135
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configuration software, 134
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Magelis operation, 164
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PL7 program overview, 157
PL7 section, 158
PL7 variable list, 157
Process data objects, 145
Saving the project with SyCon, 147
Setting baud rate, 130
Setting network node address, 130
Starting communication, 152

CANopen process data objects, 145
Concept

Hardware configuration Profibus DP, 57
Importing the Profibus DP bus 
configuration, 60
INTERBUS program overview, 111
INTERBUS variable list, 111
Master parameters Profibus DP, 65
Parameterizing I/O addresses for 
Profibus DP, 64
Profibus DP Master parameterizing, 63
Profibus DP variable list, 75
Program overview Profibus DP, 75
Section for INTERBUS, 112
Section for Profibus DP, 76

Configuration
Advantys STB with CANopen, 127
Advantys STB with INTERBUS, 90
Advantys STB with Profibus DP, 37

Configure bus
CANopen, 137
INTERBUS, 100

Configure master
CANopen in PL7, 149
INTERBUS, 101, 103
Profibus DP, 47

Configure slave
INTERBUS, 101

Configuring MMI (SyCon)
Profibus DP, 52

Configuring slave (SyCon)
Profibus DP, 50

Create bus project
CANopen, 135
INTERBUS, 100
Profibus DP, 44
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Configuration using Concept, 56
172
D
Define master

CANopen, 137
INTERBUS, 103
Profibus DP, 46

Download
Advantys application with CANopen, 131
Advantys application with INTERBUS, 93
Advantys application with Profibus DP, 
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EDS file

INTERBUS, 96
Enter bus

INTERBUS, 98
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Fieldbus master

CANopen, 21
INTERBUS, 20
Profibus DP, 20
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Advantys STB Island, 19
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CANopen, 122
INTERBUS, 86
MMI terminal Magelis, 23
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Profibus DP, 32
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Input data storage, 108
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Output data storage, 110
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Application page (Profibus DP), 79
Configuration for CANopen, 160
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Advantys STB with CANopen, 128
Advantys STB with INTERBUS, 91
Advantys STB with Profibus DP, 38
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Startup, 98
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INTERBUS, 110
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CANopen program overview, 157
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Configuring CANopen connection, 150
Configuring CANopen master, 149
Loading the application, 152
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